summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/gnupg/gnupg-2.0.1-r3.ebuild')
-rw-r--r--app-crypt/gnupg/gnupg-2.0.1-r3.ebuild95
1 files changed, 0 insertions, 95 deletions
diff --git a/app-crypt/gnupg/gnupg-2.0.1-r3.ebuild b/app-crypt/gnupg/gnupg-2.0.1-r3.ebuild
deleted file mode 100644
index 25ef9100b209..000000000000
--- a/app-crypt/gnupg/gnupg-2.0.1-r3.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-2.0.1-r3.ebuild,v 1.1 2007/01/29 20:01:35 alonbl Exp $
-
-inherit eutils flag-o-matic autotools
-
-DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
-HOMEPAGE="http://www.gnupg.org/"
-SRC_URI="mirror://gnupg/gnupg/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="bzip2 X doc ldap nls openct pcsc-lite smartcard selinux"
-
-COMMON_DEPEND="
- virtual/libc
- >=dev-libs/pth-1.3.7
- >=dev-libs/libgcrypt-1.2.0
- >=dev-libs/libksba-1.0.0
- >=dev-libs/libgpg-error-1.4
- >=dev-libs/libassuan-1.0.1
- bzip2? ( app-arch/bzip2 )
- pcsc-lite? ( >=sys-apps/pcsc-lite-1.3.0 )
- openct? ( >=dev-libs/openct-0.5.0 )
- ldap? ( net-nds/openldap )
- app-crypt/pinentry"
-
-DEPEND="${COMMON_DEPEND}
- nls? ( sys-devel/gettext )
- doc? ( sys-apps/texinfo )"
-
-RDEPEND="${COMMON_DEPEND}
- !app-crypt/gpg-agent
- !<=app-crypt/gnupg-2.0.1
- X? ( || ( media-gfx/xloadimage media-gfx/xli ) )
- virtual/mta
- selinux? ( sec-policy/selinux-gnupg )
- nls? ( virtual/libintl )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${PN}-2.0.1-bsd-make.patch"
- epatch "${FILESDIR}/${P}-agent.patch"
-
- AT_M4DIR="m4 gl/m4" eautoreconf
-}
-
-src_compile() {
- local myconf=""
-
- if use X; then
- local viewer
- if has_version 'media-gfx/xloadimage'; then
- viewer=/usr/bin/xloadimage
- else
- viewer=/usr/bin/xli
- fi
- myconf="${myconf} --with-photo-viewer=${viewer}"
- else
- myconf="${myconf} --disable-photo-viewers"
- fi
-
- append-ldflags $(bindnow-flags)
-
- econf \
- --enable-symcryptrun \
- --enable-gpg \
- --enable-gpgsm \
- --enable-agent \
- $(use_enable bzip2) \
- $(use_enable smartcard scdaemon) \
- $(use_enable nls) \
- $(use_enable ldap) \
- --disable-capabilities \
- ${myconf} \
- || die
- emake || die
- if use doc; then
- cd doc
- emake html || die
- fi
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- dodoc ChangeLog NEWS README THANKS TODO VERSION
-
- dosym gpg2 /usr/bin/gpg
- dosym gpgv2 /usr/bin/gpgv
-
- use doc && dohtml doc/gnupg.html/* doc/*jpg doc/*png
-}
-