summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/md5deep/ChangeLog8
-rw-r--r--app-crypt/md5deep/files/md5deep-4.2-strict-aliasing.patch24
-rw-r--r--app-crypt/md5deep/md5deep-3.4.ebuild17
-rw-r--r--app-crypt/md5deep/md5deep-3.7.ebuild17
-rw-r--r--app-crypt/md5deep/md5deep-3.9.1.ebuild14
-rw-r--r--app-crypt/md5deep/md5deep-3.9.ebuild14
-rw-r--r--app-crypt/md5deep/md5deep-4.0.0.ebuild16
-rw-r--r--app-crypt/md5deep/md5deep-4.0.1.ebuild16
-rw-r--r--app-crypt/md5deep/md5deep-4.2.ebuild22
9 files changed, 7 insertions, 141 deletions
diff --git a/app-crypt/md5deep/ChangeLog b/app-crypt/md5deep/ChangeLog
index edbd1aa72119..789a181bfe93 100644
--- a/app-crypt/md5deep/ChangeLog
+++ b/app-crypt/md5deep/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/md5deep
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/md5deep/ChangeLog,v 1.75 2013/12/21 16:24:41 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/md5deep/ChangeLog,v 1.76 2013/12/27 22:45:49 tristan Exp $
+
+ 27 Dec 2013; Tristan Heaven <tristan@gentoo.org> -md5deep-3.4.ebuild,
+ -md5deep-3.7.ebuild, -md5deep-3.9.ebuild, -md5deep-3.9.1.ebuild,
+ -md5deep-4.0.0.ebuild, -md5deep-4.0.1.ebuild, -md5deep-4.2.ebuild,
+ -files/md5deep-4.2-strict-aliasing.patch:
+ Remove old versions
21 Dec 2013; Agostino Sarubbo <ago@gentoo.org> md5deep-4.3.ebuild:
Stable for ppc, wrt bug #488070
diff --git a/app-crypt/md5deep/files/md5deep-4.2-strict-aliasing.patch b/app-crypt/md5deep/files/md5deep-4.2-strict-aliasing.patch
deleted file mode 100644
index 64e03957df6c..000000000000
--- a/app-crypt/md5deep/files/md5deep-4.2-strict-aliasing.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- trunk/src/md5.c 2012/01/05 22:57:35 577
-+++ trunk/src/md5.c 2012/07/02 12:34:09 644
-@@ -143,8 +143,19 @@
- byteReverse(ctx->in, 14);
-
- /* Append length in bits and transform */
-- ((uint32_t *) ctx->in)[14] = ctx->bits[0];
-- ((uint32_t *) ctx->in)[15] = ctx->bits[1];
-+
-+ // the two lines below generated this error:
-+ // "md5.c:147:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]"
-+
-+ //((uint32_t *) ctx->in)[14] = ctx->bits[0];
-+ //((uint32_t *) ctx->in)[15] = ctx->bits[1];
-+
-+ // We will manually expand the cast into two statements to make
-+ // the compiler happy...
-+
-+ uint32_t *ctxin = (uint32_t *)ctx->in;
-+ ctxin[14] = ctx->bits[0];
-+ ctxin[15] = ctx->bits[1];
-
- MD5Transform(ctx->buf, (uint32_t *) ctx->in);
- byteReverse((unsigned char *) ctx->buf, 4);
diff --git a/app-crypt/md5deep/md5deep-3.4.ebuild b/app-crypt/md5deep/md5deep-3.4.ebuild
deleted file mode 100644
index 898d49d29f6c..000000000000
--- a/app-crypt/md5deep/md5deep-3.4.ebuild
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/md5deep/md5deep-3.4.ebuild,v 1.6 2012/03/18 15:11:26 armin76 Exp $
-
-DESCRIPTION="Expanded md5sum program with recursive and comparison options"
-HOMEPAGE="http://md5deep.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="public-domain GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
-}
diff --git a/app-crypt/md5deep/md5deep-3.7.ebuild b/app-crypt/md5deep/md5deep-3.7.ebuild
deleted file mode 100644
index 8df4a513b086..000000000000
--- a/app-crypt/md5deep/md5deep-3.7.ebuild
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/md5deep/md5deep-3.7.ebuild,v 1.2 2012/03/18 15:11:26 armin76 Exp $
-
-DESCRIPTION="Expanded md5sum program with recursive and comparison options"
-HOMEPAGE="http://md5deep.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="public-domain GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README TODO
-}
diff --git a/app-crypt/md5deep/md5deep-3.9.1.ebuild b/app-crypt/md5deep/md5deep-3.9.1.ebuild
deleted file mode 100644
index 12bfd8b6d8fb..000000000000
--- a/app-crypt/md5deep/md5deep-3.9.1.ebuild
+++ /dev/null
@@ -1,14 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/md5deep/md5deep-3.9.1.ebuild,v 1.7 2012/08/27 17:59:22 armin76 Exp $
-
-EAPI=4
-
-DESCRIPTION="Expanded md5sum program with recursive and comparison options"
-HOMEPAGE="http://md5deep.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="public-domain GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
diff --git a/app-crypt/md5deep/md5deep-3.9.ebuild b/app-crypt/md5deep/md5deep-3.9.ebuild
deleted file mode 100644
index 5218c5dd8a54..000000000000
--- a/app-crypt/md5deep/md5deep-3.9.ebuild
+++ /dev/null
@@ -1,14 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/md5deep/md5deep-3.9.ebuild,v 1.2 2012/03/18 15:11:26 armin76 Exp $
-
-EAPI=4
-
-DESCRIPTION="Expanded md5sum program with recursive and comparison options"
-HOMEPAGE="http://md5deep.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="public-domain GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
diff --git a/app-crypt/md5deep/md5deep-4.0.0.ebuild b/app-crypt/md5deep/md5deep-4.0.0.ebuild
deleted file mode 100644
index c5188e17d4a5..000000000000
--- a/app-crypt/md5deep/md5deep-4.0.0.ebuild
+++ /dev/null
@@ -1,16 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/md5deep/md5deep-4.0.0.ebuild,v 1.4 2012/08/27 17:59:22 armin76 Exp $
-
-EAPI=4
-
-DESCRIPTION="Expanded md5sum program with recursive and comparison options"
-HOMEPAGE="http://md5deep.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="public-domain GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-
-DOCS="AUTHORS ChangeLog FILEFORMAT NEWS README TODO"
diff --git a/app-crypt/md5deep/md5deep-4.0.1.ebuild b/app-crypt/md5deep/md5deep-4.0.1.ebuild
deleted file mode 100644
index fd016257ba55..000000000000
--- a/app-crypt/md5deep/md5deep-4.0.1.ebuild
+++ /dev/null
@@ -1,16 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/md5deep/md5deep-4.0.1.ebuild,v 1.7 2012/10/17 03:35:21 phajdan.jr Exp $
-
-EAPI=4
-
-DESCRIPTION="Expanded md5sum program with recursive and comparison options"
-HOMEPAGE="http://md5deep.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="public-domain GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-
-DOCS="AUTHORS ChangeLog FILEFORMAT NEWS README TODO"
diff --git a/app-crypt/md5deep/md5deep-4.2.ebuild b/app-crypt/md5deep/md5deep-4.2.ebuild
deleted file mode 100644
index 2cebe37c9247..000000000000
--- a/app-crypt/md5deep/md5deep-4.2.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/md5deep/md5deep-4.2.ebuild,v 1.3 2012/10/05 18:05:05 tristan Exp $
-
-EAPI=4
-inherit eutils
-
-DESCRIPTION="Expanded md5sum program with recursive and comparison options"
-HOMEPAGE="http://md5deep.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="public-domain GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-RESTRICT="test"
-
-DOCS="AUTHORS ChangeLog FILEFORMAT NEWS README TODO"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-strict-aliasing.patch
-}