summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/bitpim/files/bitpim-0.8.13-gentoo.patch')
-rw-r--r--app-mobilephone/bitpim/files/bitpim-0.8.13-gentoo.patch80
1 files changed, 80 insertions, 0 deletions
diff --git a/app-mobilephone/bitpim/files/bitpim-0.8.13-gentoo.patch b/app-mobilephone/bitpim/files/bitpim-0.8.13-gentoo.patch
new file mode 100644
index 000000000000..842bd84cef91
--- /dev/null
+++ b/app-mobilephone/bitpim/files/bitpim-0.8.13-gentoo.patch
@@ -0,0 +1,80 @@
+diff -Nru bitpim-0.8.13.orig/src/common.py bitpim-0.8.13/src/common.py
+--- bitpim-0.8.13.orig/src/common.py 2006-04-11 05:50:29.000000000 +0300
++++ bitpim-0.8.13/src/common.py 2006-04-20 20:13:54.116823750 +0300
+@@ -681,4 +681,4 @@
+ # windows running from exe, return as is
+ return os.path.abspath(os.path.dirname(sys.executable))
+ # running from src, up one
+- return os.path.split(os.path.abspath(os.path.dirname(sys.argv[0])))[0]
++ return os.path.abspath(os.path.dirname(sys.argv[0]))
+diff -Nru bitpim-0.8.13.orig/src/conversions.py bitpim-0.8.13/src/conversions.py
+--- bitpim-0.8.13.orig/src/conversions.py 2006-03-04 01:37:32.000000000 +0200
++++ bitpim-0.8.13/src/conversions.py 2006-04-20 20:13:54.116823750 +0300
+@@ -20,11 +20,11 @@
+
+ class ConversionFailed(Exception): pass
+
+-helperdir=os.path.join(common.get_main_dir(), "helpers")
++helperdir="/usr/bin"
+
+ osext={'win32': '.exe',
+ 'darwin': '.mbin',
+- 'linux2': '.lbin'} \
++ 'linux2': ''} \
+ [sys.platform]
+
+ # This shortname crap is needed because Windows programs (including ffmpeg)
+@@ -125,14 +125,14 @@
+ p=sys.path[0]
+ if os.path.isfile(p):
+ p=os.path.dirname(p)
+- helpersdirectory=os.path.abspath(os.path.join(p, 'helpers'))
++ helpersdirectory="/usr/bin"
+ print "Helper Directory: "+helpersdirectory
+ if sys.platform=='win32':
+ osext=".exe"
+ if sys.platform=='darwin':
+ osext=".mbin"
+ if sys.platform=='linux2':
+- osext=".lbin"
++ osext=""
+
+ pngtopnmbin=gethelperbinary('pngtopnm')
+ ppmquantbin=gethelperbinary('ppmquant')
+diff -Nru bitpim-0.8.13.orig/src/native/av/bmp2avi/Makefile bitpim-0.8.13/src/native/av/bmp2avi/Makefile
+--- bitpim-0.8.13.orig/src/native/av/bmp2avi/Makefile 2005-02-18 08:55:03.000000000 +0200
++++ bitpim-0.8.13/src/native/av/bmp2avi/Makefile 2006-04-20 20:15:01.029005500 +0300
+@@ -11,9 +11,6 @@
+ $(error PLATFORM not defined. Valid PLATFORM are windows, linux, mac)
+ endif
+
+-CXXFLAGS=
+-LDFLAGS=
+-
+ ifeq ($(PLATFORM), windows)
+ EXT=exe
+ # define this for cygwin/mingw
+@@ -22,7 +19,7 @@
+ endif
+
+ ifeq ($(PLATFORM), linux)
+-EXT=lbin
++EXT=
+ endif
+
+ ifeq ($(PLATFORM), mac)
+@@ -31,13 +28,9 @@
+ CXXFLAGS+=-D__BIG_ENDIAN__
+ endif
+
+-ifeq ($(EXT),)
+-$(error PLATFORM $(PLATFORM) is invalid. Valid PLATFORM are windows, linux, mac)
+-endif
+-
+ SRC=avi_file.cxx bmp_file.cxx b2a.cxx
+ OBJ=$(SRC:.cxx=.o)
+-EXE=bmp2avi.$(EXT)
++EXE=bmp2avi
+ CXX=g++
+
+ all: $(EXE)