summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/barry/barry-0.16.ebuild')
-rw-r--r--app-pda/barry/barry-0.16.ebuild38
1 files changed, 20 insertions, 18 deletions
diff --git a/app-pda/barry/barry-0.16.ebuild b/app-pda/barry/barry-0.16.ebuild
index dadd223bfd03..4f4f4410b1a5 100644
--- a/app-pda/barry/barry-0.16.ebuild
+++ b/app-pda/barry/barry-0.16.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/barry/barry-0.16.ebuild,v 1.6 2010/05/26 08:53:27 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/barry/barry-0.16.ebuild,v 1.7 2010/10/03 05:19:55 dirtyepic Exp $
-inherit autotools base
+EAPI="3"
-DESCRIPTION="Allow synchronization, backup, restore,
-program management, and charging for BlackBerry devices"
+inherit eutils
+
+DESCRIPTION="Sync, backup, program management, and charging for BlackBerry devices"
HOMEPAGE="http://www.netdirect.ca/software/packages/barry/"
SRC_URI="mirror://sourceforge/barry/${P}.tar.bz2"
@@ -18,41 +19,41 @@ DEPEND="dev-libs/libusb
dev-libs/openssl
dev-util/pkgconfig
sys-libs/zlib
- boost? ( >=dev-libs/boost-1.33 )
+ boost? ( >=dev-libs/boost-1.33 )
doc? ( >=app-doc/doxygen-1.5.6 )
gui? ( >=dev-cpp/gtkmm-2.4
>=dev-cpp/libglademm-2.4
>=dev-cpp/glibmm-2.4
>=dev-libs/libtar-1.2.11-r2 )
opensync? ( =app-pda/libopensync-0.22* )"
+
RDEPEND="dev-libs/libusb
sys-libs/zlib
- boost? ( >=dev-libs/boost-1.33 )
+ boost? ( >=dev-libs/boost-1.33 )
gui? ( >=dev-cpp/gtkmm-2.4
>=dev-cpp/libglademm-2.4
>=dev-cpp/glibmm-2.4 )
opensync? ( =app-pda/libopensync-0.22* )"
-PATCHES=(
- "${FILESDIR}/${P}-gcc45.patch"
- "${FILESDIR}/${P}-asneeded.patch"
- )
-
-src_unpack(){
- base_src_unpack
- cd "${S}"
- eautoreconf
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc45.patch
+ sed -i -e '/bdptest_LDADD =/ s:\(.*\):\1 ../src/libbarry.la:' tools/Makefile.in
+ # Think twice about running eautoreconf here. Upstream seems to like
+ # patching the generated files directly and the sources don't remotely
+ # match anymore. See bug #319795.
}
-src_compile(){
+src_configure() {
econf \
$(use_enable boost) \
$(use_enable gui) \
$(use_with gui libtar /usr) \
$(use_with gui libz) \
$(use_enable opensync opensync-plugin)
+}
- emake || die
+src_compile() {
+ emake || die "emake failed"
if use doc ; then
cd "${S}"
@@ -62,8 +63,9 @@ src_compile(){
src_install() {
emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README || die
+
if use doc; then
- dodoc AUTHORS NEWS README || die
dohtml doc/www/doxygen/html/* || die
fi