summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/aspell/aspell-0.50.5-r4.ebuild')
-rw-r--r--app-text/aspell/aspell-0.50.5-r4.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-text/aspell/aspell-0.50.5-r4.ebuild b/app-text/aspell/aspell-0.50.5-r4.ebuild
index e46698249628..563c3ffd064a 100644
--- a/app-text/aspell/aspell-0.50.5-r4.ebuild
+++ b/app-text/aspell/aspell-0.50.5-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.5-r4.ebuild,v 1.13 2006/01/17 01:42:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.5-r4.ebuild,v 1.14 2006/03/19 19:21:57 arj Exp $
inherit libtool eutils flag-o-matic
@@ -27,6 +27,9 @@ src_compile() {
if [ "${ARCH}" == "ppc" ] || [ "${ARCH}" == "ppc-macos" ]; then
append-flags -O2 -fsigned-char
fi
+ if [ "${ARCH}" == "alpha" ]; then
+ replace-flags -Os -O2
+ fi
use gpm && append-ldflags -lgpm
filter-flags -fno-rtti
elibtoolize --reverse-deps