summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.75.0.ebuild')
-rw-r--r--app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.75.0.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.75.0.ebuild b/app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.75.0.ebuild
new file mode 100644
index 000000000000..7f586813bea2
--- /dev/null
+++ b/app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.75.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.75.0.ebuild,v 1.1 2009/05/22 22:36:12 flameeyes Exp $
+
+DESCRIPTION="XSL Stylesheets for Docbook"
+HOMEPAGE="http://wiki.docbook.org/topic/DocBookXslStylesheets"
+SRC_URI="mirror://sourceforge/docbook/docbook-xsl-${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-libs/libxml2
+ dev-libs/libxslt )"
+
+RDEPEND=">=app-text/build-docbook-catalog-1.1"
+
+S=${WORKDIR}/docbook-xsl-${PV}
+
+# Makefile is broken in this release
+RESTRICT=test
+
+# The makefile runs tests, not builds.
+src_compile() { :; }
+
+src_test() {
+ emake check || die "test failed"
+}
+
+src_install() {
+ # Create the installation directory
+ DEST="/usr/share/sgml/docbook/xsl-stylesheets"
+ insinto ${DEST}
+
+ local i
+ for sheet in $(find . -maxdepth 1 -mindepth 1 -type d); do
+ i=$(basename $sheet)
+ cd "${S}"/${i}
+ for doc in ChangeLog README; do
+ if [ -e "$doc" ]; then
+ mv ${doc} ${doc}.${i}
+ dodoc ${doc}.${i}
+ rm ${doc}.${i}
+ fi
+ done
+
+ doins -r "${S}"/${i}
+ done
+
+ # Install misc. docs
+ # The changelog is now zipped, and copied as the RELEASE-NOTES, so we
+ # don't need to install it
+ cd "${S}"
+ dodoc AUTHORS BUGS NEWS README RELEASE-NOTES.txt TODO
+ doins VERSION
+}
+
+pkg_postinst() {
+ build-docbook-catalog
+}
+
+pkg_postrm() {
+ build-docbook-catalog
+}