summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/o3read')
-rw-r--r--app-text/o3read/ChangeLog5
-rw-r--r--app-text/o3read/o3read-0.0.4.ebuild17
2 files changed, 16 insertions, 6 deletions
diff --git a/app-text/o3read/ChangeLog b/app-text/o3read/ChangeLog
index 4c7daa04b7e3..d2d59f044fd2 100644
--- a/app-text/o3read/ChangeLog
+++ b/app-text/o3read/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/o3read
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/o3read/ChangeLog,v 1.14 2008/10/18 15:06:48 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/o3read/ChangeLog,v 1.15 2008/12/30 21:36:23 angelos Exp $
+
+ 30 Dec 2008; Christoph Mende <angelos@gentoo.org> o3read-0.0.4.ebuild:
+ QA: Respect CC (bug 243738), respect CFLAGS (bug 240139), fix test suite
18 Oct 2008; nixnut <nixnut@gentoo.org> o3read-0.0.4.ebuild:
Stable on ppc wrt bug 233424
diff --git a/app-text/o3read/o3read-0.0.4.ebuild b/app-text/o3read/o3read-0.0.4.ebuild
index 096d41ddf558..e42069c5f143 100644
--- a/app-text/o3read/o3read-0.0.4.ebuild
+++ b/app-text/o3read/o3read-0.0.4.ebuild
@@ -1,23 +1,30 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/o3read/o3read-0.0.4.ebuild,v 1.7 2008/10/18 15:06:48 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/o3read/o3read-0.0.4.ebuild,v 1.8 2008/12/30 21:36:23 angelos Exp $
+
+inherit toolchain-funcs
DESCRIPTION="Converts OpenOffice formats to text or HTML."
HOMEPAGE="http://siag.nu/o3read/"
-SRC_URI="http://siag.nu/pub/o3read/${P}.tar.gz"
+SRC_URI="http://siag.nu/pub/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
+IUSE="test"
-DEPEND="app-arch/unzip"
+DEPEND="test? ( app-arch/unzip
+ www-client/lynx )"
src_compile() {
- emake || die
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
}
src_install() {
dobin o3read o3totxt o3tohtml utf8tolatin1
doman o3read.1 o3tohtml.1 o3totxt.1 utf8tolatin1.1
}
+
+src_test() {
+ emake lytest || die "make lytest failed"
+}