summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/recode/recode-3.6.ebuild')
-rw-r--r--app-text/recode/recode-3.6.ebuild27
1 files changed, 10 insertions, 17 deletions
diff --git a/app-text/recode/recode-3.6.ebuild b/app-text/recode/recode-3.6.ebuild
index 782742c12a6a..dfa75792172f 100644
--- a/app-text/recode/recode-3.6.ebuild
+++ b/app-text/recode/recode-3.6.ebuild
@@ -1,34 +1,29 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/recode/recode-3.6.ebuild,v 1.15 2003/06/28 16:00:37 mholzer Exp $
-
-IUSE="nls"
-
-inherit flag-o-matic
+# $Header: /var/cvsroot/gentoo-x86/app-text/recode/recode-3.6.ebuild,v 1.16 2003/08/05 15:56:04 vapier Exp $
+inherit flag-o-matic gcc
replace-flags "-march=pentium4" "-march=pentium3"
-S=${WORKDIR}/${P}
DESCRIPTION="Convert files between various character sets."
-SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/recode/"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc ~ppc"
+IUSE="nls"
DEPEND="virtual/glibc
nls? ( sys-devel/gettext )"
-
-KEYWORDS="x86 sparc ~ppc"
-SLOT="0"
-LICENSE="GPL-2"
-
src_compile() {
-
local myconf=""
use nls || myconf="--disable-nls"
# gcc-3.2 crashes if we don't remove any -O?
- if [ ! -z "`gcc --version | grep 3.2`" ] && [ ${ARCH} == "x86" ] ; then
- CFLAGS=${CFLAGS/-O?/}
+ if [ ! -z "`gcc-version`" == "3.2" ] && [ ${ARCH} == "x86" ] ; then
+ filter-flags -O?
fi
./configure --host=${CHOST} \
--prefix=/usr \
@@ -40,7 +35,6 @@ src_compile() {
}
src_install() {
-
make prefix=${D}/usr \
mandir=${D}/usr/share/man \
infodir=${D}/usr/share/info \
@@ -49,4 +43,3 @@ src_install() {
dodoc AUTHORS BACKLOG COPYING* ChangeLog INSTALL
dodoc NEWS README THANKS TODO
}
-