summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/ttf2pt1/ttf2pt1-3.4.4.ebuild')
-rw-r--r--app-text/ttf2pt1/ttf2pt1-3.4.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/ttf2pt1/ttf2pt1-3.4.4.ebuild b/app-text/ttf2pt1/ttf2pt1-3.4.4.ebuild
new file mode 100644
index 000000000000..00b515d228d5
--- /dev/null
+++ b/app-text/ttf2pt1/ttf2pt1-3.4.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ttf2pt1/ttf2pt1-3.4.4.ebuild,v 1.1 2007/07/16 02:30:10 dirtyepic Exp $
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="True Type Font to Postscript Type 1 Converter"
+HOMEPAGE="http://ttf2pt1.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ttf2pt1/${P}.tgz"
+
+LICENSE="ttf2pt1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/freetype-2.0"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+ epatch "${FILESDIR}/${PN}-3.4.0-man-pages.diff"
+ epatch "${FILESDIR}/${P}-freetype.patch"
+
+ sed -i -e "/^CC=/ { s:gcc:$(tc-getCC): }" Makefile
+ sed -i -e "/^CFLAGS_SYS=/ { s:-O.*$:${CFLAGS}: }" Makefile
+ sed -i -e "/^LIBS_FT=/ { s:-L/usr/lib:-L/usr/$(get_libdir): }" Makefile
+ sed -i -e "/^LIBXDIR =/ { s:libexec:$(get_libdir): }" Makefile
+}
+
+src_compile() {
+ emake all || die
+}
+
+src_install() {
+ emake INSTDIR=${D}/usr install || die
+ dodir /usr/share/doc/${PF}/html
+ cd ${D}/usr/share/ttf2pt1
+ rm -r app other
+ mv *.html ../doc/${PF}/html
+ mv [A-Z]* ../doc/${PF}
+ prepalldocs
+}