summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/chm2pdf/ChangeLog7
-rw-r--r--app-text/chm2pdf/chm2pdf-0.9.1.ebuild13
2 files changed, 13 insertions, 7 deletions
diff --git a/app-text/chm2pdf/ChangeLog b/app-text/chm2pdf/ChangeLog
index 48d68955cc45..0deaf8b2848f 100644
--- a/app-text/chm2pdf/ChangeLog
+++ b/app-text/chm2pdf/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/chm2pdf
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/chm2pdf/ChangeLog,v 1.4 2009/07/15 13:26:55 fauli Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/chm2pdf/ChangeLog,v 1.5 2010/04/22 17:54:13 hwoarang Exp $
+
+ 22 Apr 2010; Markos Chandras <hwoarang@gentoo.org> chm2pdf-0.9.1.ebuild:
+ Refactor ebuild to use python functions correctly. Fixes bug #312097
15 Jul 2009; Christian Faulhammer <fauli@gentoo.org> chm2pdf-0.9.1.ebuild:
stable x86, bug 277724
diff --git a/app-text/chm2pdf/chm2pdf-0.9.1.ebuild b/app-text/chm2pdf/chm2pdf-0.9.1.ebuild
index ea3fd2cc6e78..0f85a918d145 100644
--- a/app-text/chm2pdf/chm2pdf-0.9.1.ebuild
+++ b/app-text/chm2pdf/chm2pdf-0.9.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/chm2pdf/chm2pdf-0.9.1.ebuild,v 1.3 2009/07/15 13:26:55 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/chm2pdf/chm2pdf-0.9.1.ebuild,v 1.4 2010/04/22 17:54:13 hwoarang Exp $
EAPI="2"
-
+PYTHON_DEPEND="2"
inherit eutils
DESCRIPTION="A script that converts a CHM file into a single PDF file."
@@ -17,8 +17,11 @@ IUSE=""
RDEPEND="dev-python/pychm
app-text/htmldoc
- dev-libs/chmlib
- dev-lang/python"
+ dev-libs/chmlib"
+
+pkg_setup() {
+ python_set_active_version 2
+}
src_prepare(){
epatch "${FILESDIR}/tempdir.patch"