summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/libassa')
-rw-r--r--dev-cpp/libassa/ChangeLog7
-rw-r--r--dev-cpp/libassa/files/libassa-3.5.0-link-dynamically.patch15
-rw-r--r--dev-cpp/libassa/libassa-3.5.0.ebuild16
3 files changed, 32 insertions, 6 deletions
diff --git a/dev-cpp/libassa/ChangeLog b/dev-cpp/libassa/ChangeLog
index de08345c0718..95cc0de663b2 100644
--- a/dev-cpp/libassa/ChangeLog
+++ b/dev-cpp/libassa/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/libassa
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libassa/ChangeLog,v 1.12 2011/03/20 19:17:39 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libassa/ChangeLog,v 1.13 2011/07/19 20:33:31 angelos Exp $
+
+ 19 Jul 2011; Christoph Mende <angelos@gentoo.org> libassa-3.5.0.ebuild,
+ +files/libassa-3.5.0-link-dynamically.patch:
+ Add USE=doc to control docs installation and fix insecure rpaths by linking
+ dynamically
20 Mar 2011; Christoph Mende <angelos@gentoo.org> libassa-3.5.0.ebuild:
Made building of static libraries optional and removed .la files
diff --git a/dev-cpp/libassa/files/libassa-3.5.0-link-dynamically.patch b/dev-cpp/libassa/files/libassa-3.5.0-link-dynamically.patch
new file mode 100644
index 000000000000..883fed474961
--- /dev/null
+++ b/dev-cpp/libassa/files/libassa-3.5.0-link-dynamically.patch
@@ -0,0 +1,15 @@
+diff --git a/utils/Makefile.am b/utils/Makefile.am
+index 82c2345..6550015 100644
+--- a/utils/Makefile.am
++++ b/utils/Makefile.am
+@@ -15,8 +15,8 @@ noinst_PROGRAMS = bytereader
+ ASSADIR = ${top_srcdir}/assa
+ INCLUDES = -I$(top_srcdir)
+
+-LDFLAGS += -static
+-LDADD = $(top_builddir)/assa/libassa-@ASSA_RELEASE@.la @WIN32_EXTRA_LIBADD@
++LDFLAGS += -L$(top_builddir)/assa/.libs
++LIBS = -lassa-3.5
+
+ bytereader_SOURCES = bytereader.cpp
+
diff --git a/dev-cpp/libassa/libassa-3.5.0.ebuild b/dev-cpp/libassa/libassa-3.5.0.ebuild
index 03da6e14e105..86cee054a811 100644
--- a/dev-cpp/libassa/libassa-3.5.0.ebuild
+++ b/dev-cpp/libassa/libassa-3.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libassa/libassa-3.5.0.ebuild,v 1.9 2011/03/20 19:17:39 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libassa/libassa-3.5.0.ebuild,v 1.10 2011/07/19 20:33:31 angelos Exp $
EAPI=3
inherit autotools eutils
@@ -12,23 +12,29 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="static-libs"
+IUSE="doc static-libs"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
src_prepare() {
epatch "${FILESDIR}"/${P}-gcc44.patch \
"${FILESDIR}"/${P}-dont-run-ldconfig.patch \
"${FILESDIR}"/${P}-fix-tests.patch \
- "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-link-dynamically.patch
AT_M4DIR="${S}/macros"
eautoreconf
}
src_configure() {
- econf $(use_enable static-libs static)
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable doc doxygen)
}
src_install() {
emake DESTDIR="${D}" install || die "install failed"
dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
- find "${ED}" -name "*.la" -delete || die "failed to delete .la files"
+ find "${ED}" -name "*.la" -exec rm -rf {} + || die "failed to delete .la files"
}