summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild')
-rw-r--r--dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild b/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild
index d3958e3e72bd..a55e4a79daab 100644
--- a/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild
+++ b/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild,v 1.5 2003/08/18 01:13:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild,v 1.6 2003/08/24 22:21:58 vapier Exp $
inherit cvs
ECVS_SERVER="cvs.sourceforge.net:/cvsroot/crystal"
@@ -43,5 +43,9 @@ src_install() {
make INSTALL_DIR=${D}/${CRYSTAL_PREFIX} install || die
dodir /usr/bin
dosym ${CRYSTAL_PREFIX}/bin/cs-config /usr/bin/cs-config
- echo "CRYSTAL=\"${CRYSTAL_PREFIX}\"" > 90crystalspace
+ find ${D}/${CRYSTAL_PREFIX} -type f -exec chmod a+r '{}' \;
+ find ${D}/${CRYSTAL_PREFIX} -type d -exec chmod a+rx '{}' \;
+ chmod a+rx ${D}/${CRYSTAL_PREFIX}/{bin,lib}/*
+ dodir /etc/env.d
+ echo "CRYSTAL=\"${CRYSTAL_PREFIX}\"" > ${D}/etc/env.d/90crystalspace
}