summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/esqueleto/esqueleto-1.3.5.ebuild')
-rw-r--r--dev-haskell/esqueleto/esqueleto-1.3.5.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-haskell/esqueleto/esqueleto-1.3.5.ebuild b/dev-haskell/esqueleto/esqueleto-1.3.5.ebuild
new file mode 100644
index 000000000000..3fc0d7ec14d1
--- /dev/null
+++ b/dev-haskell/esqueleto/esqueleto-1.3.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/esqueleto/esqueleto-1.3.5.ebuild,v 1.1 2014/03/09 12:41:24 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+#hackport: flags: -mysql,-postgresql
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit eutils haskell-cabal
+
+DESCRIPTION="Bare bones, type-safe EDSL for SQL queries on persistent backends."
+HOMEPAGE="https://github.com/meteficha/esqueleto"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/conduit:=[profile?]
+ dev-haskell/monad-logger:=[profile?]
+ >=dev-haskell/persistent-1.3:=[profile?] <dev-haskell/persistent-1.4:=[profile?]
+ dev-haskell/resourcet:=[profile?]
+ >=dev-haskell/tagged-0.2:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3 <dev-haskell/hspec-1.9
+ dev-haskell/hunit
+ dev-haskell/monad-control
+ >=dev-haskell/persistent-sqlite-1.2 <dev-haskell/persistent-sqlite-1.4
+ >=dev-haskell/persistent-template-1.2 <dev-haskell/persistent-template-1.4
+ dev-haskell/quickcheck )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.6-haddock.patch
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-mysql \
+ --flag=-postgresql
+}