summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/commons-net/commons-net-1.0.0.ebuild')
-rw-r--r--dev-java/commons-net/commons-net-1.0.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-java/commons-net/commons-net-1.0.0.ebuild b/dev-java/commons-net/commons-net-1.0.0.ebuild
new file mode 100644
index 000000000000..35e35023328a
--- /dev/null
+++ b/dev-java/commons-net/commons-net-1.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.0.0.ebuild,v 1.1 2003/03/22 12:30:24 absinthe Exp $
+
+inherit jakarta-commons
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="The purpose of the library is to provide fundamental protocol access, not higher-level abstractions."
+HOMEPAGE="http://jakarta.apache.org/commons/net/index.html"
+SRC_URI="http://www.apache.org/dist/jakarta/commons/net/source/${P}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4"
+RDEPEND=">=virtual/jdk-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc jikes junit"
+
+src_compile() {
+ jakarta-commons_src_compile myconf make
+ jakarta-commons_src_install dojar
+ use doc && jakarta-commons_src_compile makedoc
+ use doc && jakarta-commons_src_install html
+}