summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/commons-pool/commons-pool-1.0.1-r3.ebuild')
-rw-r--r--dev-java/commons-pool/commons-pool-1.0.1-r3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-java/commons-pool/commons-pool-1.0.1-r3.ebuild b/dev-java/commons-pool/commons-pool-1.0.1-r3.ebuild
new file mode 100644
index 000000000000..5dae6e8324ee
--- /dev/null
+++ b/dev-java/commons-pool/commons-pool-1.0.1-r3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/commons-pool-1.0.1-r3.ebuild,v 1.6 2004/03/19 07:14:58 zx Exp $
+
+inherit jakarta-commons
+
+S=${WORKDIR}/${PN}-${PV}-src
+DESCRIPTION="Jakarta-Commons component providing general purpose object pooling API"
+HOMEPAGE="http://jakarta.apache.org/commons/pool/"
+SRC_URI="http://archive.apache.org/dist/jakarta/commons/pool/source/${P}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4
+ >=dev-java/commons-collections-2.0
+ junit? ( >=junit-3.7 )"
+RDEPEND=">=virtual/jre-1.3
+ >=dev-java/commons-collections-2.0"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="x86 ppc sparc"
+IUSE="doc jikes junit"
+
+src_compile() {
+ echo "commons-collections.jar=`java-config --classpath=commons-collections`" >> build.properties
+ jakarta-commons_src_compile myconf make
+ jakarta-commons_src_install dojar
+ use doc && jakarta-commons_src_compile makedoc
+ use doc && jakarta-commons_src_install html
+}