summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/openssl/ChangeLog8
-rw-r--r--dev-libs/openssl/Manifest9
-rw-r--r--dev-libs/openssl/files/digest-openssl-0.9.7b-r32
-rw-r--r--dev-libs/openssl/openssl-0.9.7b-r1.ebuild14
-rw-r--r--dev-libs/openssl/openssl-0.9.7b-r2.ebuild14
-rw-r--r--dev-libs/openssl/openssl-0.9.7b-r3.ebuild166
-rw-r--r--dev-libs/openssl/openssl-0.9.7b.ebuild14
7 files changed, 218 insertions, 9 deletions
diff --git a/dev-libs/openssl/ChangeLog b/dev-libs/openssl/ChangeLog
index 6257d688bb53..e1ec316d88f2 100644
--- a/dev-libs/openssl/ChangeLog
+++ b/dev-libs/openssl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/openssl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.47 2003/09/23 15:48:27 darkspecter Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.48 2003/09/24 18:28:05 azarah Exp $
+
+ 24 Sep 2003; Martin Schlemmer <azarah@gentoo.org> openssl-0.9.7b-r1.ebuild,
+ openssl-0.9.7b-r2.ebuild, openssl-0.9.7b.ebuild:
+ Breaks things one some boxen, bug #13795. The problem is that if we have
+ a 'gcc fixed' version in $(gcc-config -L) from 0.9.6, then breaks as it was
+ defined as 'int BN_mod(...)' and in 0.9.7 it is a #define with BN_div(...).
23 Sep 2003; Bartosch Pixa <darkspecter@gentoo.org> openssl-0.9.6j.ebuild:
set ppc in keywords
diff --git a/dev-libs/openssl/Manifest b/dev-libs/openssl/Manifest
index e7ae732e14ed..6759feb5f923 100644
--- a/dev-libs/openssl/Manifest
+++ b/dev-libs/openssl/Manifest
@@ -1,9 +1,10 @@
MD5 f9d38a7d3bb44d57cb055f5ef7e0de50 openssl-0.9.6j.ebuild 2616
MD5 7c732dae05a3589d0fef59bb8e29a6de openssl-0.9.6i-r2.ebuild 2934
-MD5 d1b66cbf4df0443e63bf70ebd1d88f9a openssl-0.9.7b.ebuild 3324
-MD5 0a0e86871d6a7e331e68f0d252699492 openssl-0.9.7b-r1.ebuild 3325
-MD5 c659606873dd348b531a4cb242fbe796 ChangeLog 8121
-MD5 ce77d15761cd320ae87c9bffb015b261 openssl-0.9.7b-r3.ebuild 4785
+MD5 bee7f7d295c5ab4a59b610864cac52b2 openssl-0.9.7b.ebuild 3326
+MD5 bccdef95a514ea24ef57cb33ba5a8ddc openssl-0.9.7b-r1.ebuild 3329
+MD5 f176cc4b3cd9a270b91e43f9f295817b ChangeLog 8478
+MD5 f110bafc5ab22d7c5529adddca5c9312 openssl-0.9.7b-r3.ebuild 4790
+MD5 c45b530f18d54873bea8bcaff1b73f03 openssl-0.9.7b-r2.ebuild 4790
MD5 55db5f2d56b9146b7d7cae1353a0e0c4 files/digest-openssl-0.9.7b-r3 134
MD5 8c719455d9438ab2eb36279f5befe581 files/digest-openssl-0.9.6i-r2 67
MD5 ec3ece282da08b6e27d213ee22c00208 files/digest-openssl-0.9.7b 67
diff --git a/dev-libs/openssl/files/digest-openssl-0.9.7b-r3 b/dev-libs/openssl/files/digest-openssl-0.9.7b-r3
new file mode 100644
index 000000000000..e4517ebe6214
--- /dev/null
+++ b/dev-libs/openssl/files/digest-openssl-0.9.7b-r3
@@ -0,0 +1,2 @@
+MD5 fae4bec090fa78e20f09d76d55b6ccff openssl-0.9.7b.tar.gz 2784331
+MD5 52ea996e52bcea5120f193f51469bbb1 openssl-0.9.6j.tar.gz 2182643
diff --git a/dev-libs/openssl/openssl-0.9.7b-r1.ebuild b/dev-libs/openssl/openssl-0.9.7b-r1.ebuild
index 707f9ecace95..7e2791c04519 100644
--- a/dev-libs/openssl/openssl-0.9.7b-r1.ebuild
+++ b/dev-libs/openssl/openssl-0.9.7b-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7b-r1.ebuild,v 1.1 2003/09/03 02:49:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7b-r1.ebuild,v 1.2 2003/09/24 18:28:05 azarah Exp $
inherit eutils
@@ -85,3 +85,15 @@ src_install() {
}
+pkg_postinst() {
+ local BN_H="${ROOT}$(gcc-config -L)/include/openssl/bn.h"
+ # Breaks things one some boxen, bug #13795. The problem is that
+ # if we have a 'gcc fixed' version in $(gcc-config -L) from 0.9.6,
+ # then breaks as it was defined as 'int BN_mod(...)' and in 0.9.7 it
+ # is a define with BN_div(...) - <azarah@gentoo.org> (24 Sep 2003)
+ if [ -f "${BN_H}" ] && [ -n "$(grep '^int[[:space:]]*BN_mod(' "${BN_H}")" ]
+ then
+ rm -f "${BN_H}"
+ fi
+}
+
diff --git a/dev-libs/openssl/openssl-0.9.7b-r2.ebuild b/dev-libs/openssl/openssl-0.9.7b-r2.ebuild
index bf4bbf1b3b57..70d42b4bf0a5 100644
--- a/dev-libs/openssl/openssl-0.9.7b-r2.ebuild
+++ b/dev-libs/openssl/openssl-0.9.7b-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7b-r2.ebuild,v 1.4 2003/09/19 13:41:06 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7b-r2.ebuild,v 1.5 2003/09/24 18:28:05 azarah Exp $
inherit eutils flag-o-matic gcc
@@ -10,7 +10,7 @@ fi
OLD_096_P="${PN}-0.9.6j"
-S=${WORKDIR}
+S="${WORKDIR}"
DESCRIPTION="Toolkit for SSL v2/v3 and TLS v1"
SRC_URI="mirror://openssl/source/${P}.tar.gz
mirror://openssl/source/${OLD_096_P}.tar.gz"
@@ -146,6 +146,16 @@ src_install() {
}
pkg_postinst() {
+ local BN_H="${ROOT}$(gcc-config -L)/include/openssl/bn.h"
+ # Breaks things one some boxen, bug #13795. The problem is that
+ # if we have a 'gcc fixed' version in $(gcc-config -L) from 0.9.6,
+ # then breaks as it was defined as 'int BN_mod(...)' and in 0.9.7 it
+ # is a define with BN_div(...) - <azarah@gentoo.org> (24 Sep 2003)
+ if [ -f "${BN_H}" ] && [ -n "$(grep '^int[[:space:]]*BN_mod(' "${BN_H}")" ]
+ then
+ rm -f "${BN_H}"
+ fi
+
test -f ${ROOT}/usr/lib/libssl.so.0.9.6 && {
einfo "You can now re-compile all packages that are linked against"
einfo "OpenSSL 0.9.6 by using revdep-rebuild from gentoolkit:"
diff --git a/dev-libs/openssl/openssl-0.9.7b-r3.ebuild b/dev-libs/openssl/openssl-0.9.7b-r3.ebuild
new file mode 100644
index 000000000000..7a9076f84e5f
--- /dev/null
+++ b/dev-libs/openssl/openssl-0.9.7b-r3.ebuild
@@ -0,0 +1,166 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7b-r3.ebuild,v 1.1 2003/09/24 18:28:05 azarah Exp $
+
+inherit eutils flag-o-matic gcc
+
+if [ "$( gcc-version )" == "3.3" ]; then
+ filter-flags "-fprefetch-loop-arrays"
+fi
+
+OLD_096_P="${PN}-0.9.6j"
+
+S="${WORKDIR}"
+DESCRIPTION="Toolkit for SSL v2/v3 and TLS v1"
+SRC_URI="mirror://openssl/source/${P}.tar.gz
+ mirror://openssl/source/${OLD_096_P}.tar.gz"
+HOMEPAGE="http://www.openssl.org/"
+
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ >=sys-apps/sed-4"
+LICENSE="as-is"
+SLOT="0"
+
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~mips ~hppa ~arm ia64"
+
+src_unpack() {
+ unpack ${A}
+
+ # openssl-0.9.7
+ cd ${WORKDIR}/${P}
+
+ epatch ${FILESDIR}/${P}-gentoo.diff
+
+ if [ "${ARCH}" = "hppa" ]; then
+ sed -i -e \
+ 's!^"linux-parisc"\(.*\)::BN\(.*\)::!"linux-parisc"\1:-ldl:BN\2::::::::::dlfcn:linux-shared:-fPIC::.so.\\$(SHLIB_MAJOR).\\$(SHLIB_MINOR)!' \
+ Configure
+ fi
+ if [ "${ARCH}" = "alpha" -a "${CC}" != "ccc" ]; then
+ # ccc compiled openssl will break things linked against
+ # a gcc compiled openssl, the configure will automatically detect
+ # ccc and use it, so stop that if user hasnt asked for it.
+ sed -i -e \
+ 's!CC=ccc!CC=gcc!' config
+ fi
+
+ sed -i -e "s/-O3/$CFLAGS/" -e "s/-m486//" Configure
+
+ # openssl-0.9.6
+ test -f ${ROOT}/usr/lib/libssl.so.0.9.6 && {
+ cd ${WORKDIR}/${OLD_096_P}
+
+ epatch ${FILESDIR}/${OLD_096_P}-gentoo.diff
+
+ case ${ARCH} in
+ mips)
+ epatch ${FILESDIR}/openssl-0.9.6-mips.diff
+ ;;
+ arm)
+ # patch linker to add -ldl or things linking aginst libcrypto fail
+ sed -i -e \
+ 's!^"linux-elf-arm"\(.*\)::BN\(.*\)!"linux-elf-arm"\1:-ldl:BN\2!' \
+ Configure
+ ;;
+ hppa)
+ sed -i -e \
+ 's!^"linux-parisc"\(.*\)::BN\(.*\)::!"linux-parisc"\1:-ldl:BN\2::::::::::dlfcn:linux-shared:-fPIC::.so.\\$(SHLIB_MAJOR).\\$(SHLIB_MINOR)!' \
+ Configure
+ esac
+
+ sed -i -e "s/-O3/$CFLAGS/" -e "s/-m486//" Configure
+ }
+}
+
+src_compile() {
+ # openssl-0.9.7
+ cd ${WORKDIR}/${P}
+ ./config --prefix=/usr --openssldir=/etc/ssl shared threads || die
+ einfo "Compiling ${P}"
+ make all || die
+
+ # openssl-0.9.6
+ test -f ${ROOT}/usr/lib/libssl.so.0.9.6 && {
+ cd ${WORKDIR}/${OLD_096_P}
+
+ if [ "$PROFILE_ARCH" = "sparc" -a "`uname -m`" = "sparc64" ]; then
+ SSH_TARGET="linux-sparcv8"
+ elif [ "`uname -m`" = "parisc64" ]; then
+ SSH_TARGET="linux-parisc"
+ fi
+
+ case ${CHOST} in
+ alphaev56*|alphaev6*)
+ SSH_TARGET="linux-alpha+bwx-${CC:-gcc}"
+ ;;
+ alpha*)
+ SSH_TARGET="linux-alpha-${CC:-gcc}" ;;
+ esac
+
+ if [ ${SSH_TARGET} ]; then
+ einfo "Forcing ${SSH_TARGET} compile"
+ ./Configure ${SSH_TARGET} --prefix=/usr \
+ --openssldir=/etc/ssl shared threads || die
+ else
+ ./config --prefix=/usr --openssldir=/etc/ssl shared threads || die
+ fi
+
+ einfo "Compiling ${OLD_096_P}"
+ make all || die
+ }
+}
+
+src_install() {
+ # openssl-0.9.7
+ cd ${WORKDIR}/${P}
+ make INSTALL_PREFIX=${D} MANDIR=/usr/share/man install || die
+ dodoc CHANGES* FAQ LICENSE NEWS README
+ dodoc doc/*.txt
+ dohtml doc/*
+ insinto /usr/share/emacs/site-lisp
+ doins doc/c-indentation.el
+
+ # create the certs directory. Previous openssl builds
+ # would need to create /usr/lib/ssl/certs but this looks
+ # to be the more FHS compliant setup... -raker
+ insinto /etc/ssl/certs
+ doins certs/*.pem
+ OPENSSL=${D}/usr/bin/openssl /usr/bin/perl tools/c_rehash ${D}/etc/ssl/certs
+
+ # The man pages rand.3 and passwd.1 conflict with other packages
+ # Rename them to ssl-* and also make a symlink from openssl-* to ssl-*
+ cd ${D}/usr/share/man/man1
+ mv passwd.1 ssl-passwd.1
+ ln -sf ssl-passwd.1 openssl-passwd.1
+ cd ${D}/usr/share/man/man3
+ mv rand.3 ssl-rand.3
+ ln -sf ssl-rand.3 openssl-rand.3
+
+ # openssl-0.9.6
+ test -f ${ROOT}/usr/lib/libssl.so.0.9.6 && {
+ dolib.so ${WORKDIR}/${OLD_096_P}/libcrypto.so.0.9.6
+ dolib.so ${WORKDIR}/${OLD_096_P}/libssl.so.0.9.6
+ }
+}
+
+pkg_postinst() {
+ local BN_H="${ROOT}$(gcc-config -L)/include/openssl/bn.h"
+ # Breaks things one some boxen, bug #13795. The problem is that
+ # if we have a 'gcc fixed' version in $(gcc-config -L) from 0.9.6,
+ # then breaks as it was defined as 'int BN_mod(...)' and in 0.9.7 it
+ # is a define with BN_div(...) - <azarah@gentoo.org> (24 Sep 2003)
+ if [ -f "${BN_H}" ] && [ -n "$(grep '^int[[:space:]]*BN_mod(' "${BN_H}")" ]
+ then
+ rm -f "${BN_H}"
+ fi
+
+ test -f ${ROOT}/usr/lib/libssl.so.0.9.6 && {
+ einfo "You can now re-compile all packages that are linked against"
+ einfo "OpenSSL 0.9.6 by using revdep-rebuild from gentoolkit:"
+ einfo "# revdep-rebuild --soname libssl.so.0.9.6"
+ einfo "# revdep-rebuild --soname libcrypto.so.0.9.6"
+ einfo "After this, you can delete /usr/lib/libssl.so.0.9.6 and /usr/lib/libcrypto.so.0.9.6"
+ }
+}
diff --git a/dev-libs/openssl/openssl-0.9.7b.ebuild b/dev-libs/openssl/openssl-0.9.7b.ebuild
index 748b33bcbefd..b77cd026cf39 100644
--- a/dev-libs/openssl/openssl-0.9.7b.ebuild
+++ b/dev-libs/openssl/openssl-0.9.7b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7b.ebuild,v 1.5 2003/06/22 08:04:03 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7b.ebuild,v 1.6 2003/09/24 18:28:05 azarah Exp $
inherit eutils
@@ -85,3 +85,15 @@ src_install() {
}
+pkg_postinst() {
+ local BN_H="${ROOT}$(gcc-config -L)/include/openssl/bn.h"
+ # Breaks things one some boxen, bug #13795. The problem is that
+ # if we have a 'gcc fixed' version in $(gcc-config -L) from 0.9.6,
+ # then breaks as it was defined as 'int BN_mod(...)' and in 0.9.7 it
+ # is a define with BN_div(...) - <azarah@gentoo.org> (24 Sep 2003)
+ if [ -f "${BN_H}" ] && [ -n "$(grep '^int[[:space:]]*BN_mod(' "${BN_H}")" ]
+ then
+ rm -f "${BN_H}"
+ fi
+}
+