summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/groupoffice/groupoffice-1.94.ebuild')
-rw-r--r--dev-php/groupoffice/groupoffice-1.94.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/dev-php/groupoffice/groupoffice-1.94.ebuild b/dev-php/groupoffice/groupoffice-1.94.ebuild
deleted file mode 100644
index 44df656ec459..000000000000
--- a/dev-php/groupoffice/groupoffice-1.94.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/groupoffice/groupoffice-1.94.ebuild,v 1.4 2004/01/08 08:40:44 robbat2 Exp $
-
-inherit webapp-apache
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Group-Office is a powerfull modular Intranet application framework. It runs *nix using PHP and has several database support."
-HOMEPAGE="http://group-office.sourceforge.net/"
-SRC_URI="mirror://sourceforge/group-office/${P}.tar.gz
- mirror://sourceforge/group-office/GO-theme-crystal-1.93.tar.gz"
-RESTRICT="nomirror"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~alpha ~amd64 ~sparc ~hppa "
-
-DEPEND="virtual/php
- dev-db/mysql"
-
-webapp-detect || NO_WEBSERVER=1
-
-pkg_setup() {
- webapp-pkg_setup "${NO_WEBSERVER}"
- if [ -d ${HTTPD_ROOT}/${PN} ] ; then
- ewarn "You need to unmerge your old ${PN} version first."
- ewarn "${PN} will be installed into ${HTTPD_ROOT}/${PN}"
- ewarn "directly instead of a version-dependant directory."
- die "need to unmerge old version first"
- fi
-
- einfo "Installing into ${ROOT}${HTTPD_ROOT}."
-}
-
-src_unpack() {
- unpack ${A}
- unpack GO-theme-crystal-1.93.tar.gz
-}
-
-src_install() {
- webapp-mkdirs
-
- local DocumentRoot=${HTTPD_ROOT}
- local destdir=${DocumentRoot}/${PN}
-
- mkdir -p ${D}${destdir}
- mv ${WORKDIR}/crystal ${S}/themes
- cd ${S}
- dodoc CHANGELOG DEVELOPERS FAQ INSTALL RELEASE README.ldap TODO TRANSLATORS
- rm -rf CHANGELOG FAQ INSTALL README.ldap TODO TRANSLATORS
-
- cp -r . ${D}${destdir}
-
- cd "${D}/${HTTPD_ROOT}"
- chown -R "${HTTPD_USER}:${HTTPD_GROUP}" ${PN}
- # Fix permissions
- find ${D}${destdir} -type d | xargs chmod 755
- find ${D}${destdir} -type f | xargs chmod 644
-}
-
-pkg_postinst() {
- einfo "Follow the instructions at /usr/share/doc/${PF}/INSTALL"
- einfo "to complete the install. You need to add MySQL users"
- einfo "and configure ${PN}"
-}