summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/phpdbg')
-rw-r--r--dev-php/phpdbg/ChangeLog5
-rw-r--r--dev-php/phpdbg/Manifest4
-rw-r--r--dev-php/phpdbg/files/digest-phpdbg-2.11.231
-rw-r--r--dev-php/phpdbg/phpdbg-2.11.23.ebuild45
4 files changed, 52 insertions, 3 deletions
diff --git a/dev-php/phpdbg/ChangeLog b/dev-php/phpdbg/ChangeLog
index 4bc5301e9f01..eb4595d7ef4e 100644
--- a/dev-php/phpdbg/ChangeLog
+++ b/dev-php/phpdbg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-php/phpdbg
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phpdbg/ChangeLog,v 1.5 2003/10/14 03:41:09 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpdbg/ChangeLog,v 1.6 2003/10/19 18:53:29 stuart Exp $
+
+ 19 Oct 2003; Stuart Herbert <stuart@gentoo.org> :
+ Version bump; closes bug #23870
13 Oct 2003; Robin H. Johnson <robbat2@gentoo.org> metadata.xml:
add metadata.xml
diff --git a/dev-php/phpdbg/Manifest b/dev-php/phpdbg/Manifest
index 6b5402391eb8..880c4ca9c22f 100644
--- a/dev-php/phpdbg/Manifest
+++ b/dev-php/phpdbg/Manifest
@@ -1,8 +1,8 @@
MD5 5741a7c0645dbea6ce4d29dbcbe93b16 phpdbg-2.10-r1.ebuild 1391
MD5 a9a223f8be4e984c161a094b6299d973 phpdbg-2.10.ebuild 658
-MD5 c69338c3125ed2285169f2a20f27983f ChangeLog 500
+MD5 3913fc3d95342c431c16a3e4267da769 ChangeLog 586
MD5 34b376f52ca199fffb4e52b83169574a metadata.xml 156
-MD5 199305e7e17dfdb3537320ecc745870c phpdbg-2.11.23.ebuild 1143
+MD5 799f97cf595cd71fd380d59e882e541a phpdbg-2.11.23.ebuild 1242
MD5 46f62a6c5764771d7152ad657d8f45e4 files/digest-phpdbg-2.10-r1 62
MD5 a56cc9f2eaa32b6e4b0ed1a2dca2dbc3 files/digest-phpdbg-2.11.23 66
MD5 46f62a6c5764771d7152ad657d8f45e4 files/digest-phpdbg-2.10 62
diff --git a/dev-php/phpdbg/files/digest-phpdbg-2.11.23 b/dev-php/phpdbg/files/digest-phpdbg-2.11.23
new file mode 100644
index 000000000000..14e59145daa5
--- /dev/null
+++ b/dev-php/phpdbg/files/digest-phpdbg-2.11.23
@@ -0,0 +1 @@
+MD5 ddb1d141c496c8d23fe98c8de19c892e dbg-2.11.23-src.tar.gz 38506
diff --git a/dev-php/phpdbg/phpdbg-2.11.23.ebuild b/dev-php/phpdbg/phpdbg-2.11.23.ebuild
new file mode 100644
index 000000000000..6a7e752e1cdc
--- /dev/null
+++ b/dev-php/phpdbg/phpdbg-2.11.23.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpdbg/phpdbg-2.11.23.ebuild,v 1.1 2003/10/19 18:53:29 stuart Exp $
+
+PHP_EXT_NAME="dbg"
+PHP_EXT_ZENDEXT="no"
+inherit php-ext-source
+
+S="${WORKDIR}/dbg-${PV}-src"
+DESCRIPTION="A PHP debugger useable with some editors like phpedit."
+SRC_URI="http://dd.cron.ru/dbg/dnld/dbg-${PV}${PL}-src.tar.gz"
+HOMEPAGE="http://dd.cron.ru/dbg/"
+LICENSE="dbgphp"
+SLOT="0"
+DEPEND="virtual/php"
+
+# support for ppc or others?
+KEYWORDS="x86 sparc "
+
+src_compile() {
+ myconf="--enable-dbg=shared --with-dbg-profiler --with-php-config=/usr/bin/php-config"
+ php-ext-source_src_compile
+}
+
+src_install () {
+ php-ext-source_src_install
+
+ dodoc AUTHORS COPYING INSTALL
+}
+
+pkg_postinst() {
+ php-ext-base_addtoinifiles "extension" "/etc/php4/lib/dbg.so"
+ php-ext-base_addtoinifiles "[Debugger]"
+ php-ext-base_addtoinifiles "debugger.enabled" "on"
+ php-ext-base_addtoinifiles "debugger.profiler_enabled" "on"
+ einfo Please reload Apache to activate the changes
+
+}
+
+pkg_postrm() {
+ einfo You need to remove all lines referring to the debugger, and
+ extension=dbg.so.Please reload Apache to activate the changes
+
+}
+