summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycups/pycups-1.9.51.ebuild')
-rw-r--r--dev-python/pycups/pycups-1.9.51.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/pycups/pycups-1.9.51.ebuild b/dev-python/pycups/pycups-1.9.51.ebuild
deleted file mode 100644
index b0fb574e71a5..000000000000
--- a/dev-python/pycups/pycups-1.9.51.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycups/pycups-1.9.51.ebuild,v 1.3 2011/01/27 16:38:40 arfrever Exp $
-
-EAPI="2"
-
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-SUPPORT_PYTHON_ABIS="1"
-inherit distutils flag-o-matic
-
-DESCRIPTION="Python bindings for the CUPS API"
-HOMEPAGE="http://cyberelk.net/tim/data/pycups/"
-SRC_URI="http://cyberelk.net/tim/data/pycups/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
-SLOT="0"
-IUSE="doc examples"
-
-RDEPEND="
- >=net-print/cups-1.4.4
-"
-DEPEND="${RDEPEND}
- doc? ( dev-python/epydoc )
-"
-
-src_compile() {
- append-cflags -DVERSION=\\\"${PV}\\\"
- distutils_src_compile
-
- if use doc; then
- emake doc || die "emake doc failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r html/ || die "installing html docs failed"
- fi
-
- if use examples; then
- insinto /usr/share/doc/"${P}"
- doins -r examples/ || die "installing examples failed"
- fi
-}