summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/ChangeLog7
-rw-r--r--dev-python/python-docs/python-docs-2.5.2.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-python/python-docs/ChangeLog b/dev-python/python-docs/ChangeLog
index 9a0fb4aa23bd..fdff6050e69e 100644
--- a/dev-python/python-docs/ChangeLog
+++ b/dev-python/python-docs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-docs
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.104 2008/07/18 13:35:25 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.105 2008/08/07 00:23:39 jer Exp $
+
+*python-docs-2.5.2 (07 Aug 2008)
+
+ 07 Aug 2008; Jeroen Roovers <jer@gentoo.org> +python-docs-2.5.2.ebuild:
+ Version bump thanks to Michael Glockenstein (bug #234072).
18 Jul 2008; Olivier Crête <tester@gentoo.org> python-docs-2.5.1.ebuild:
Stable on amd64, bug #178800
diff --git a/dev-python/python-docs/python-docs-2.5.2.ebuild b/dev-python/python-docs/python-docs-2.5.2.ebuild
new file mode 100644
index 000000000000..f48498f04028
--- /dev/null
+++ b/dev-python/python-docs/python-docs-2.5.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.5.2.ebuild,v 1.1 2008/08/07 00:23:39 jer Exp $
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/${PV}/"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/html-${PV}.tar.bz2"
+
+LICENSE="PSF-2.2"
+SLOT="2.5"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack html-${PV}.tar.bz2
+ rm -f README python.dir
+}
+
+src_install() {
+ docinto html
+ cp -R "${S}"/Python-Docs-${PV}/* ${D}/usr/share/doc/${PF}/html
+}
+
+pkg_preinst() {
+ dodir /etc/env.d
+ echo "PYTHONDOCS=/usr/share/doc/${PF}/html/lib" > ${D}/etc/env.d/50python-docs
+}