summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/unidecode/unidecode-0.04.16.ebuild')
-rw-r--r--dev-python/unidecode/unidecode-0.04.16.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/unidecode/unidecode-0.04.16.ebuild b/dev-python/unidecode/unidecode-0.04.16.ebuild
new file mode 100644
index 000000000000..dad1b549ee10
--- /dev/null
+++ b/dev-python/unidecode/unidecode-0.04.16.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/unidecode/unidecode-0.04.16.ebuild,v 1.1 2014/05/13 16:10:34 jer Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy pypy2_0 )
+
+MY_PN=Unidecode
+MY_P=${MY_PN}-${PV}
+
+inherit distutils-r1
+
+DESCRIPTION="Module providing ASCII transliterations of Unicode text"
+HOMEPAGE="http://pypi.python.org/pypi/Unidecode"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}