summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/actionmailer/actionmailer-4.0.4.ebuild')
-rw-r--r--dev-ruby/actionmailer/actionmailer-4.0.4.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-ruby/actionmailer/actionmailer-4.0.4.ebuild b/dev-ruby/actionmailer/actionmailer-4.0.4.ebuild
deleted file mode 100644
index 9dd74593abf3..000000000000
--- a/dev-ruby/actionmailer/actionmailer-4.0.4.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-4.0.4.ebuild,v 1.2 2014/04/21 06:16:00 graaff Exp $
-
-EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Framework for designing email-service layers"
-HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "~dev-ruby/actionpack-${PV}
- >=dev-ruby/mail-2.5.4:2.5"
-ruby_add_bdepend "test? (
- dev-ruby/test-unit:2
- dev-ruby/mocha:0.13
-)"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
- rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
-
- # Make sure we use the test-unit gem since ruby18 does not provide
- # all the test-unit features needed.
- sed -i -e '1igem "test-unit"' test/abstract_unit.rb || die
-}