summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/cocaine/cocaine-0.4.2.ebuild')
-rw-r--r--dev-ruby/cocaine/cocaine-0.4.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/cocaine/cocaine-0.4.2.ebuild b/dev-ruby/cocaine/cocaine-0.4.2.ebuild
new file mode 100644
index 000000000000..68e9ecf9aefc
--- /dev/null
+++ b/dev-ruby/cocaine/cocaine-0.4.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/cocaine/cocaine-0.4.2.ebuild,v 1.1 2012/12/16 09:31:48 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A small library for doing command lines"
+HOMEPAGE="http://www.thoughtbot.com/projects/cocaine"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/bourne
+ dev-ruby/mocha
+ )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/git ls-files/d' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
+
+ rm Gemfile* || die
+
+ sed -i -e '/bundler/d' Rakefile || die
+
+ sed -i -e '/pry/ s:^:#:' spec/spec_helper.rb || die
+}