summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/mini_magick/mini_magick-3.7.0.ebuild')
-rw-r--r--dev-ruby/mini_magick/mini_magick-3.7.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/mini_magick/mini_magick-3.7.0.ebuild b/dev-ruby/mini_magick/mini_magick-3.7.0.ebuild
new file mode 100644
index 000000000000..9818af36e4f3
--- /dev/null
+++ b/dev-ruby/mini_magick/mini_magick-3.7.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mini_magick/mini_magick-3.7.0.ebuild,v 1.1 2014/01/18 07:10:01 graaff Exp $
+
+EAPI=5
+
+# jruby → test_tempfile_at_path_after_format fails with jruby 1.3.1,
+# sounds like a bug in JRuby itself, or the code not being compatible.
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Manipulate images with minimal use of memory."
+HOMEPAGE="http://github.com/minimagick/minimagick"
+SRC_URI="https://github.com/minimagick/minimagick/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="minimagick-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# It's only used at runtime in this case because this extension only
+# _calls_ the commands. But when we run tests we're going to need tiff
+# and jpeg support at a minimum.
+RDEPEND="media-gfx/imagemagick"
+DEPEND="test? ( media-gfx/imagemagick[tiff,jpeg] )"
+
+ruby_add_rdepend ">=dev-ruby/subexec-0.2.1"
+
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ # remove executable bit from all files
+ find "${S}" -type f -exec chmod -x {} +
+
+ sed -i -e '/[Bb]undler/ s:^:#:' spec/spec_helper.rb || die
+
+ # Don't force a specific formatter but use overall Gentoo defaults.
+ sed -i -e '/config.formatter/d' spec/spec_helper.rb || die
+}