summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/stomp/stomp-1.2.2.ebuild')
-rw-r--r--dev-ruby/stomp/stomp-1.2.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/stomp/stomp-1.2.2.ebuild b/dev-ruby/stomp/stomp-1.2.2.ebuild
new file mode 100644
index 000000000000..9880148c5cf3
--- /dev/null
+++ b/dev-ruby/stomp/stomp-1.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/stomp/stomp-1.2.2.ebuild,v 1.1 2012/04/21 07:33:13 graaff Exp $
+
+EAPI="2"
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
+
+# There is also a test task but that requires a live stomp server.
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby bindings for the stomp messaging protocol"
+HOMEPAGE="http://rubyforge.org/projects/stomp/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"