summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/wxruby/wxruby-0.5.ebuild')
-rw-r--r--dev-ruby/wxruby/wxruby-0.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/wxruby/wxruby-0.5.ebuild b/dev-ruby/wxruby/wxruby-0.5.ebuild
new file mode 100644
index 000000000000..abde9bce9900
--- /dev/null
+++ b/dev-ruby/wxruby/wxruby-0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/wxruby/wxruby-0.5.ebuild,v 1.1 2004/08/29 15:50:27 twp Exp $
+
+MY_P="${PN}-${PV}-src"
+DESCRIPTION="Ruby language bindings for the wxWidgets GUI toolkit"
+HOMEPAGE="http://rubyforge.org/projects/wxruby/"
+SRC_URI="http://rubyforge.org/frs/download.php/1254/${MY_P}.tgz"
+LICENSE="wxWinLL-3"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="unicode"
+DEPEND=">=dev-lang/ruby-1.8
+ >=x11-libs/wxGTK-2.4.1"
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ use unicode && die "${CATEGORY}/${PN} is incompatible with USE=\"unicode\""
+}
+
+src_compile() {
+ ( cd src && ruby extconf.rb && emake ) || die
+}
+
+src_install() {
+ dodoc [A-Z]*
+ cp -r samples ${D}/usr/share/doc/${PF}
+ ( cd src && make DESTDIR=${D} install )
+}