summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/sysprof/sysprof-1.0.3.ebuild')
-rw-r--r--dev-util/sysprof/sysprof-1.0.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/sysprof/sysprof-1.0.3.ebuild b/dev-util/sysprof/sysprof-1.0.3.ebuild
new file mode 100644
index 000000000000..f00981548471
--- /dev/null
+++ b/dev-util/sysprof/sysprof-1.0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/sysprof/sysprof-1.0.3.ebuild,v 1.1 2006/06/11 16:32:29 vapier Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="System-wide Linux Profiler"
+HOMEPAGE="http://www.daimi.au.dk/~sandmann/sysprof/"
+SRC_URI="http://www.daimi.au.dk/~sandmann/sysprof/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2.6"
+
+pkg_setup() {
+ MODULE_NAMES="sysprof-module(misc:${S}/module)"
+ CONFIG_CHECK="PROFILING"
+ PROFILING_ERROR="You need to enable Profiling support in your kernel."
+ BUILD_TARGETS="all"
+ linux-mod_pkg_setup
+}
+
+src_compile() {
+ econf --disable-kernel-module || die
+ emake || die
+ linux-mod_src_compile
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ linux-mod_src_install
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ make_desktop_entry sysprof Sysprof sysprof-icon.png
+}