summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/moon-buggy/moon-buggy-1.0.ebuild')
-rw-r--r--games-action/moon-buggy/moon-buggy-1.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/games-action/moon-buggy/moon-buggy-1.0.ebuild b/games-action/moon-buggy/moon-buggy-1.0.ebuild
deleted file mode 100644
index 60d69979c3af..000000000000
--- a/games-action/moon-buggy/moon-buggy-1.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/moon-buggy/moon-buggy-1.0.ebuild,v 1.7 2007/10/01 00:27:54 mr_bones_ Exp $
-
-inherit autotools eutils games
-
-DESCRIPTION="A simple console game, where you drive a car across the moon's surface"
-HOMEPAGE="http://www.seehuhn.de/comp/moon-buggy.html"
-SRC_URI="http://www.seehuhn.de/data/${P}.tar.gz
- esd? ( http://www.seehuhn.de/data/${PN}-sound-${PV}.tar.gz )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="esd"
-
-DEPEND="esd? ( media-sound/esound )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e '/$(DESTDIR)$(bindir)\/moon-buggy -c/d' \
- Makefile.am \
- || die "sed Makefile.am failed"
- use esd && epatch sound.patch
- rm -f missing
- eautoreconf
-}
-
-src_compile() {
- egamesconf --sharedstatedir="${GAMES_STATEDIR}" || die
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc ANNOUNCE AUTHORS ChangeLog NEWS README* TODO
- touch "${D}${GAMES_STATEDIR}"/${PN}/mbscore
- fperms 664 "${GAMES_STATEDIR}"/${PN}/mbscore
- prepgamesdirs
-}