summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action')
-rw-r--r--games-action/super-hexagon/ChangeLog5
-rw-r--r--games-action/super-hexagon/super-hexagon-15.ebuild8
2 files changed, 7 insertions, 6 deletions
diff --git a/games-action/super-hexagon/ChangeLog b/games-action/super-hexagon/ChangeLog
index 1c0ea7f261ff..35c1c404f8b6 100644
--- a/games-action/super-hexagon/ChangeLog
+++ b/games-action/super-hexagon/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/super-hexagon
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/super-hexagon/ChangeLog,v 1.1 2013/03/21 21:58:14 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/super-hexagon/ChangeLog,v 1.2 2013/03/23 21:20:31 hasufell Exp $
+
+ 23 Mar 2013; Julian Ospald <hasufell@gentoo.org> super-hexagon-15.ebuild:
+ use unpack_zip from unpacker.eclass
*super-hexagon-15 (21 Mar 2013)
diff --git a/games-action/super-hexagon/super-hexagon-15.ebuild b/games-action/super-hexagon/super-hexagon-15.ebuild
index 97e27ce23015..770073978776 100644
--- a/games-action/super-hexagon/super-hexagon-15.ebuild
+++ b/games-action/super-hexagon/super-hexagon-15.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/super-hexagon/super-hexagon-15.ebuild,v 1.2 2013/03/22 21:31:22 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/super-hexagon/super-hexagon-15.ebuild,v 1.3 2013/03/23 21:20:31 hasufell Exp $
EAPI=5
-inherit eutils games
+inherit eutils unpacker games
DESCRIPTION="A minimal action game by Terry Cavanagh, with music by Chipzel"
HOMEPAGE="http://www.superhexagon.com/"
@@ -51,9 +51,7 @@ pkg_nofetch() {
}
src_unpack() {
- # self unpacking zip archive; unzip warns about the exe stuff
- unzip -q "${DISTDIR}"/${A}
- [[ $? -gt 1 ]] && die "unpacking failed"
+ unpack_zip ${A}
}
src_prepare() {