summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/fgrun/fgrun-1.5.2.ebuild')
-rw-r--r--games-simulation/fgrun/fgrun-1.5.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-simulation/fgrun/fgrun-1.5.2.ebuild b/games-simulation/fgrun/fgrun-1.5.2.ebuild
new file mode 100644
index 000000000000..b343cabf947e
--- /dev/null
+++ b/games-simulation/fgrun/fgrun-1.5.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/fgrun-1.5.2.ebuild,v 1.1 2010/03/19 20:29:56 tupone Exp $
+
+EAPI=2
+inherit autotools eutils multilib games
+
+DESCRIPTION="A graphical frontend for the FlightGear Flight Simulator"
+HOMEPAGE="http://sourceforge.net/projects/fgrun"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-games/simgear
+ || (
+ <x11-libs/fltk-1.1.9:1.1[opengl]
+ >=x11-libs/fltk-1.1.9:1.1[opengl,threads]
+ )"
+RDEPEND="${DEPEND}
+ >=games-simulation/flightgear-1.9.0"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}"-fltk.patch
+ AT_M4DIR=. eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --with-plib-libraries=/usr/$(get_libdir) \
+ --with-plib-includes=/usr/include
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS
+ prepgamesdirs
+}