summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/dconf')
-rw-r--r--gnome-base/dconf/ChangeLog6
-rw-r--r--gnome-base/dconf/dconf-0.14.1.ebuild72
-rw-r--r--gnome-base/dconf/dconf-0.16.0.ebuild74
3 files changed, 5 insertions, 147 deletions
diff --git a/gnome-base/dconf/ChangeLog b/gnome-base/dconf/ChangeLog
index 61f8ce9493e8..695578aa4e32 100644
--- a/gnome-base/dconf/ChangeLog
+++ b/gnome-base/dconf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-base/dconf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/dconf/ChangeLog,v 1.48 2013/08/01 13:22:33 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/dconf/ChangeLog,v 1.49 2013/08/11 09:44:32 eva Exp $
+
+ 11 Aug 2013; Gilles Dartiguelongue <eva@gentoo.org> -dconf-0.14.1.ebuild,
+ -dconf-0.16.0.ebuild:
+ Clean up old revisions.
01 Aug 2013; Alexandre Rostovtsev <tetromino@gentoo.org> dconf-0.16.0.ebuild,
dconf-0.16.1.ebuild:
diff --git a/gnome-base/dconf/dconf-0.14.1.ebuild b/gnome-base/dconf/dconf-0.14.1.ebuild
deleted file mode 100644
index 2cc3adb09da0..000000000000
--- a/gnome-base/dconf/dconf-0.14.1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/dconf/dconf-0.14.1.ebuild,v 1.3 2013/06/26 13:42:44 tetromino Exp $
-
-EAPI="4"
-GCONF_DEBUG="no"
-
-inherit gnome2 bash-completion-r1 virtualx
-
-DESCRIPTION="Simple low-level configuration system"
-HOMEPAGE="http://live.gnome.org/dconf"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-# TODO: coverage ?
-IUSE="test +X"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~arm-linux ~x86-linux"
-
-RDEPEND="
- >=dev-libs/glib-2.33.3:2
- sys-apps/dbus
- X? (
- >=dev-libs/libxml2-2.7.7:2
- >=x11-libs/gtk+-3.4:3 )
-"
-DEPEND="${RDEPEND}
- dev-libs/libxslt
- >=dev-util/gtk-doc-am-1.15
- >=dev-util/intltool-0.50
- sys-devel/gettext
- virtual/pkgconfig
-"
-
-src_configure() {
- G2CONF="${G2CONF}
- --disable-gcov
- $(use_enable X editor)
- VALAC=$(type -P valac-0.18)" # harmless even if valac-0.18 not found
- gnome2_src_configure
-}
-
-src_test() {
- Xemake check
-}
-
-src_install() {
- gnome2_src_install
-
- # GSettings backend may be one of: memory, gconf, dconf
- # Only dconf is really considered functional by upstream
- # must have it enabled over gconf if both are installed
- echo 'CONFIG_PROTECT_MASK="/etc/dconf"' >> 51dconf
- echo 'GSETTINGS_BACKEND="dconf"' >> 51dconf
- doenvd 51dconf
-
- # Install bash-completion file properly to the system
- rm -rv "${ED}usr/share/bash-completion" || die
- dobashcomp "${S}/bin/completion/dconf"
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- # Kill existing dconf-service processes as recommended by upstream due to
- # possible changes in the dconf private dbus API.
- # dconf-service will be dbus-activated on next use.
- pids=$(pgrep -x dconf-service)
- if [[ $? == 0 ]]; then
- ebegin "Stopping dconf-service; it will automatically restart on demand"
- kill ${pids}
- eend $?
- fi
-}
diff --git a/gnome-base/dconf/dconf-0.16.0.ebuild b/gnome-base/dconf/dconf-0.16.0.ebuild
deleted file mode 100644
index 1f6bd1915d7f..000000000000
--- a/gnome-base/dconf/dconf-0.16.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/dconf/dconf-0.16.0.ebuild,v 1.3 2013/08/01 13:22:33 tetromino Exp $
-
-EAPI="5"
-GCONF_DEBUG="no"
-
-inherit gnome2 bash-completion-r1 virtualx
-
-DESCRIPTION="Simple low-level configuration system"
-HOMEPAGE="http://live.gnome.org/dconf"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-# TODO: coverage ?
-IUSE="test +X"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~arm-linux ~x86-linux"
-
-RDEPEND="
- >=dev-libs/glib-2.35.2:2
- sys-apps/dbus
- X? (
- >=dev-libs/libxml2-2.7.7:2
- >=x11-libs/gtk+-3.4:3 )
-"
-DEPEND="${RDEPEND}
- dev-libs/libxslt
- dev-util/gdbus-codegen
- >=dev-util/gtk-doc-am-1.15
- >=dev-util/intltool-0.50
- sys-devel/gettext
- virtual/pkgconfig
-"
-
-src_configure() {
- G2CONF="${G2CONF}
- --disable-gcov
- --enable-man
- $(use_enable X editor)
- VALAC=$(type -P valac-0.18)" # harmless even if valac-0.18 not found
- gnome2_src_configure
-}
-
-src_test() {
- Xemake check
-}
-
-src_install() {
- gnome2_src_install
-
- # GSettings backend may be one of: memory, gconf, dconf
- # Only dconf is really considered functional by upstream
- # must have it enabled over gconf if both are installed
- echo 'CONFIG_PROTECT_MASK="/etc/dconf"' >> 51dconf
- echo 'GSETTINGS_BACKEND="dconf"' >> 51dconf
- doenvd 51dconf
-
- # Install bash-completion file properly to the system
- rm -rv "${ED}usr/share/bash-completion" || die
- dobashcomp "${S}/bin/completion/dconf"
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- # Kill existing dconf-service processes as recommended by upstream due to
- # possible changes in the dconf private dbus API.
- # dconf-service will be dbus-activated on next use.
- pids=$(pgrep -x dconf-service)
- if [[ $? == 0 ]]; then
- ebegin "Stopping dconf-service; it will automatically restart on demand"
- kill ${pids}
- eend $?
- fi
-}