summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdm')
-rw-r--r--kde-base/kdm/ChangeLog7
-rw-r--r--kde-base/kdm/Manifest12
-rw-r--r--kde-base/kdm/files/digest-kdm-3.4.31
-rw-r--r--kde-base/kdm/kdm-3.4.3.ebuild63
4 files changed, 72 insertions, 11 deletions
diff --git a/kde-base/kdm/ChangeLog b/kde-base/kdm/ChangeLog
index 65bcacba5790..911c4700cb48 100644
--- a/kde-base/kdm/ChangeLog
+++ b/kde-base/kdm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdm
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdm/ChangeLog,v 1.19 2005/10/09 18:07:55 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdm/ChangeLog,v 1.20 2005/10/13 00:10:00 danarmak Exp $
+
+*kdm-3.4.3 (13 Oct 2005)
+
+ 13 Oct 2005; Dan Armak <danarmak@gentoo.org> +kdm-3.4.3.ebuild:
+ New version.
09 Oct 2005; Petteri Räty <betelgeuse@gentoo.org> kdm-3.5_beta1.ebuild:
Added ~x86 keyword.
diff --git a/kde-base/kdm/Manifest b/kde-base/kdm/Manifest
index e883f1ee6158..63782a16b147 100644
--- a/kde-base/kdm/Manifest
+++ b/kde-base/kdm/Manifest
@@ -1,18 +1,10 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 f961f3d1ee43b424ac33fc74df9281d4 ChangeLog 2765
MD5 b22a687fe2e8cf06cd5147f1ec68efb7 files/digest-kdm-3.4.1 212
MD5 7deca5e51240260b2976fbbe9326ed6d files/digest-kdm-3.4.2 287
+MD5 b334b621242eaf5a23035e870f09dea6 files/digest-kdm-3.4.3 68
MD5 b50fc512a289fe7a1ef658080cb0a0b3 files/digest-kdm-3.5_beta1 69
MD5 f8fabdf3377ba617123c9c4ed476270c kdm-3.4.1.ebuild 2429
MD5 32da1a4ba2aef00f40978e17c71c0da2 kdm-3.4.2.ebuild 2442
+MD5 32da1a4ba2aef00f40978e17c71c0da2 kdm-3.4.3.ebuild 2442
MD5 58c86c0390310e05337fc8a0082cfbe2 kdm-3.5_beta1.ebuild 2097
MD5 acc03a4b12bb0433a57e95bd253b9501 metadata.xml 156
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDSVyoQiJ/wx066S4RAnEbAJ9yMHPXizIXC+UouHfPyNpiPS3uNwCdFIXp
-TZH/S5fZpqxRUDCNfI0EBnA=
-=gjkP
------END PGP SIGNATURE-----
diff --git a/kde-base/kdm/files/digest-kdm-3.4.3 b/kde-base/kdm/files/digest-kdm-3.4.3
new file mode 100644
index 000000000000..6a8e77ebae51
--- /dev/null
+++ b/kde-base/kdm/files/digest-kdm-3.4.3
@@ -0,0 +1 @@
+MD5 7b25feba2774c077601d472dae5352c8 kdebase-3.4.3.tar.bz2 22425835
diff --git a/kde-base/kdm/kdm-3.4.3.ebuild b/kde-base/kdm/kdm-3.4.3.ebuild
new file mode 100644
index 000000000000..2c4146d5e6c8
--- /dev/null
+++ b/kde-base/kdm/kdm-3.4.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdm/kdm-3.4.3.ebuild,v 1.1 2005/10/13 00:10:00 danarmak Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE login manager, similar to xdm and gdm"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="pam"
+
+KMEXTRA="kdmlib/"
+KMEXTRACTONLY="libkonq/konq_defaults.h
+ kioslave/thumbnail/configure.in.in" # for the HAVE_LIBART test
+KMCOMPILEONLY="kcontrol/background"
+DEPEND="$DEPEND
+ pam? ( kde-base/kdebase-pam )
+ $(deprange $PV $MAXKDEVER kde-base/kcontrol)"
+ # Requires the desktop background settings and kdm modules,
+ # so until we separate the kcontrol modules into separate ebuilds :-),
+ # there's a dep here
+
+
+src_compile() {
+ use pam \
+ && myconf="$myconf --with-pam=yes" \
+ || myconf="$myconf --with-pam=no --with-shadow"
+
+ kde-meta_src_compile myconf configure
+ kde_remove_flag kdm/kfrontend -fomit-frame-pointer
+ kde-meta_src_compile make
+}
+
+src_install() {
+ kde-meta_src_install
+ cd ${S}/kdm && make DESTDIR=${D} GENKDMCONF_FLAGS="--no-old --no-backup --no-in-notice" install
+
+ # We tell kdm to /use session files from /usr/share/xsessions.
+ # I've removed some other kdmrc mods from here, since it's not clear why
+ # the default aren't ok (and I'm not sure about the benefits of using
+ # the xdm configfiles under /etc/X11 instead of our own ones),
+ # and it's the Gentoo Way to avoid modifying upstream behaviour.
+ # Tell me if you don't like this. --danarmak
+ cd ${D}/${KDEDIR}/share/config/kdm || die
+ sed -i -e "s:#SessionsDirs=:SessionsDirs=/usr/share/xsessions\n#SessionsDirs=:" \
+ -e "s:#GreetFont=:GreetFont=Sans Serif,24,-1,5,50,0,0,0,0,0\n#GreetFont=:" \
+ -e "s:#StdFont=:StdFont=Sans Serif,12,-1,5,50,0,0,0,0,0\n#StdFont=:" \
+ -e "s:#FailFont=:FailFont=Sans Serif,12,-1,5,75,0,0,0,0,0\n#FailFont=:" \
+ -e "s:#AntiAliasing=:AntiAliasing=true\n#AntiAliasing=:" \
+ kdmrc
+}
+
+pkg_postinst() {
+ # set the default kdm face icon if it's not already set by the system admin
+ # because this is user-overrideable in that way, it's not in src_install
+ if [ ! -e "${ROOT}${KDEDIR}/share/apps/kdm/faces/.default.face.icon" ]; then
+ mkdir -p "${ROOT}${KDEDIR}/share/apps/kdm/faces"
+ cp "${ROOT}${KDEDIR}/share/apps/kdm/pics/users/default1.png" \
+ "${ROOT}${KDEDIR}/share/apps/kdm/faces/.default.face.icon"
+ fi
+}