summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/qtruby/qtruby-3.5.10.ebuild')
-rw-r--r--kde-base/qtruby/qtruby-3.5.10.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-base/qtruby/qtruby-3.5.10.ebuild b/kde-base/qtruby/qtruby-3.5.10.ebuild
new file mode 100644
index 000000000000..dcb8cf3f1b89
--- /dev/null
+++ b/kde-base/qtruby/qtruby-3.5.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/qtruby-3.5.10.ebuild,v 1.1 2008/09/14 00:00:37 carlo Exp $
+
+KMNAME=kdebindings
+KMCOPYLIB="libsmokeqt smoke/qt"
+KM_MAKEFILESREV=1
+EAPI="1"
+inherit kde-meta
+
+DESCRIPTION="Ruby bindings for QT"
+HOMEPAGE="http://developer.kde.org/language-bindings/ruby/"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="
+ dev-ruby/rubygems
+ >=kde-base/smoke-${PV}:${SLOT}
+ >=virtual/ruby-1.8"
+RDEPEND="${DEPEND}"
+
+PATCHES="${FILESDIR}/no-gtk-glib-check.diff"
+
+# Because this installs into /usr/lib/ruby/..., it doesn't have SLOT=X.Y like the rest of KDE,
+# and it installs into /usr entirely.
+# Note that it still depends on a specific range of (slotted) smoke versions.
+SLOT="0"
+
+src_compile() {
+ kde_src_compile myconf
+ myconf="$myconf --prefix=/usr"
+ kde_src_compile configure make
+}