summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060814.ebuild')
-rw-r--r--media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060814.ebuild121
1 files changed, 121 insertions, 0 deletions
diff --git a/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060814.ebuild b/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060814.ebuild
new file mode 100644
index 000000000000..21bb0dce227f
--- /dev/null
+++ b/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060814.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060814.ebuild,v 1.1 2006/08/15 08:43:43 zzam Exp $
+
+inherit vdr-plugin versionator
+
+MY_PV="$(get_version_component_range 4)"
+MY_P=${PN}-cvs-${MY_PV}
+
+DESCRIPTION="VDR plugin: Software output-Device"
+HOMEPAGE="http://softdevice.berlios.de/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="xv fbcon directfb mmx mmxext xinerama"
+
+RDEPEND=">=media-video/vdr-1.3.36
+ >=media-video/ffmpeg-0.4.9_pre1
+ directfb? (
+ dev-libs/DirectFB
+ dev-libs/DFB++
+ )
+ media-libs/alsa-lib
+ xv? ( || ( ( x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXv
+ xinerama? ( x11-libs/libXinerama )
+ )
+ virtual/x11
+ ) )"
+
+DEPEND="${RDEPEND}
+ xv? ( || ( ( x11-proto/xproto
+ x11-proto/xextproto
+ x11-libs/libXv
+ xinerama? ( x11-proto/xineramaproto )
+ )
+ virtual/x11
+ ) )
+ fbcon? ( sys-kernel/linux-headers )"
+
+
+S=${WORKDIR}/${VDRPLUGIN}-cvs-${MY_PV}
+PATCHES="
+ ${FILESDIR}/vdr-softdevice-0.2.3-shm-key-init.diff
+ ${FILESDIR}/vdr-softdevice-0.2.3-shm-fullscreen.diff
+ ${FILESDIR}/softdevice-cvs-libcle266mpegdec-0.2.patch"
+
+pkg_setup() {
+ vdr-plugin_pkg_setup
+
+ if use !xv && use !fbcon && use !directfb; then
+ ewarn "You need to set at least one of these use-flags: xv fbcon directfb"
+ die "no output-method enabled"
+ fi
+
+ COMPILE_SHM=0
+ if has_version ">=media-video/vdr-1.3.0"; then
+ if use xv; then
+ COMPILE_SHM=1
+ else
+ einfo "SHM does only support xv at the moment"
+ fi
+ else
+ einfo "SHM not supported on vdr-1.2"
+ fi
+ case ${COMPILE_SHM} in
+ 0) einfo "SHM support will not be compiled." ;;
+ 1) einfo "SHM support will be compiled." ;;
+ esac
+
+ # Check for ffmpeg relying on libtheora without pkg-config-file
+ # Bug #142250
+ if built_with_use media-video/ffmpeg theora && \
+ has_version "<media-libs/libtheora/libtheora-1.0_alpha4"; then
+
+ eerror "This package will not work when using ffmpeg with"
+ eerror "USE=\"theora\" combined with media-libs/libtheora"
+ eerror "older than version 1.0_alpha4."
+ eerror "Please update to at least media-libs/libtheora-1.0_alpha4."
+ die "Please update to at least media-libs/libtheora-1.0_alpha4."
+ fi
+}
+
+src_compile() {
+ local MYOPTS=""
+ MYOPTS="${MYOPTS} --disable-vidix"
+ use xv || MYOPTS="${MYOPTS} --disable-xv"
+ use fbcon || MYOPTS="${MYOPTS} --disable-fb"
+ use directfb || MYOPTS="${MYOPTS} --disable-dfb"
+
+ # MMX-Support
+ use mmx || MYOPTS="${MYOPTS} --disable-mmx"
+ use mmxext || MYOPTS="${MYOPTS} --disable-mmx2"
+
+ use xinerama || MYOPTS="${MYOPTS} --disable-xinerama"
+
+ [[ ${COMPILE_SHM} == 1 ]] || MYOPTS="${MYOPTS} --disable-shm"
+
+ cd ${S}
+ einfo configure ${MYOPTS}
+ ./configure ${MYOPTS} || die "configure failed"
+
+ vdr-plugin_src_compile
+}
+
+src_install() {
+ vdr-plugin_src_install
+
+ insinto "${VDR_PLUGIN_DIR}"
+ doins libsoftdevice-*.so.*
+
+ if [[ "${COMPILE_SHM}" = "1" ]]; then
+ exeinto "/usr/bin"
+ doexe ShmClient
+ fi
+}
+