summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/poc/poc-0.4.1.ebuild')
-rw-r--r--media-sound/poc/poc-0.4.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/poc/poc-0.4.1.ebuild b/media-sound/poc/poc-0.4.1.ebuild
new file mode 100644
index 000000000000..91f08a2be78b
--- /dev/null
+++ b/media-sound/poc/poc-0.4.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/poc/poc-0.4.1.ebuild,v 1.1 2005/05/07 08:42:12 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="mp3 and ogg streamer (include mp3cue and mp3cut)"
+HOMEPAGE="http://www.bl0rg.net/software/poc/"
+SRC_URI="http://www.bl0rg.net/software/poc/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-devel/flex
+ sys-devel/bison"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^CFLAGS/s:-O2::' \
+ -e '/^PREFIX/s:/local::' \
+ Makefile
+ epatch "${FILESDIR}"/${P}-fec-pkt-prototype.patch
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1
+ make install DESTDIR="${D}" || die
+ dodoc README TODO
+}