summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/banshee/ChangeLog9
-rw-r--r--media-sound/banshee/banshee-0.11.5.ebuild104
-rw-r--r--media-sound/banshee/files/digest-banshee-0.11.53
3 files changed, 114 insertions, 2 deletions
diff --git a/media-sound/banshee/ChangeLog b/media-sound/banshee/ChangeLog
index 28659d6a4e0e..d7222c2935fe 100644
--- a/media-sound/banshee/ChangeLog
+++ b/media-sound/banshee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/banshee
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/ChangeLog,v 1.38 2006/12/11 02:34:12 metalgod Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/ChangeLog,v 1.39 2007/01/25 01:51:44 metalgod Exp $
+
+*banshee-0.11.5 (25 Jan 2007)
+
+ 25 Jan 2007; Luis Medinas <metalgod@gentoo.org> +banshee-0.11.5.ebuild:
+ Version Bump. Closes bug #163387.
11 Dec 2006; Luis Medinas <metalgod@gentoo.org> banshee-0.11.3.ebuild:
Fix ebuild to compile with and without boo because configure is broken for
diff --git a/media-sound/banshee/banshee-0.11.5.ebuild b/media-sound/banshee/banshee-0.11.5.ebuild
new file mode 100644
index 000000000000..e9ca616db4ca
--- /dev/null
+++ b/media-sound/banshee/banshee-0.11.5.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/banshee-0.11.5.ebuild,v 1.1 2007/01/25 01:51:44 metalgod Exp $
+
+inherit autotools eutils gnome2 mono
+
+DESCRIPTION="Banshee allows you to import CDs, sync your music collection, play
+music directly from an iPod, create playlists with songs from your library, and
+create audio and MP3 CDs from subsets of your library."
+HOMEPAGE="http://banshee-project.org"
+SRC_URI="http://banshee-project.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="aac boo doc daap encode ipod flac mad njb vorbis"
+
+RDEPEND=">=dev-lang/mono-1.1.17
+ >=dev-dotnet/gtk-sharp-2.8.0
+ >=dev-dotnet/gnomevfs-sharp-2.8.0
+ >=dev-dotnet/gconf-sharp-2.8.0
+ >=media-libs/gstreamer-0.10.0
+ >=media-libs/gst-plugins-base-0.10.0
+ >=media-libs/gst-plugins-good-0.10.0
+ >=media-libs/gst-plugins-ugly-0.10.0
+ >=media-plugins/gst-plugins-alsa-0.10.0
+ >=media-plugins/gst-plugins-gnomevfs-0.10.0
+ >=media-plugins/gst-plugins-gconf-0.10.0
+ encode? ( >=media-plugins/gst-plugins-lame-0.10.0 )
+ mad? ( >=media-plugins/gst-plugins-mad-0.10.0 )
+ vorbis? ( >=media-plugins/gst-plugins-ogg-0.10.0
+ >=media-plugins/gst-plugins-vorbis-0.10.0 )
+ flac? ( >=media-plugins/gst-plugins-flac-0.10.0 )
+ aac? ( >=media-plugins/gst-plugins-faad-0.10.0
+ >=media-libs/faad2-2.0-r4 )
+ >=media-plugins/gst-plugins-cdparanoia-0.10.0
+ >=media-libs/musicbrainz-2.1.1
+ njb? ( >=dev-dotnet/njb-sharp-0.3.0 )
+ daap? ( >=net-dns/avahi-0.6.9 )
+ >=dev-libs/glib-2.0
+ >=gnome-base/libgnomeui-2.0
+ >=gnome-base/libbonobo-2.0
+ >=gnome-base/gnome-desktop-2.0
+ ipod? ( >=dev-dotnet/ipod-sharp-0.6.0
+ >=media-plugins/gst-plugins-faac-0.10.0 )
+ >=sys-apps/hal-0.5.2
+ boo? ( >=dev-lang/boo-0.7.6 )
+ >=dev-db/sqlite-3
+ >=gnome-extra/nautilus-cd-burner-2.12"
+
+USE_DESTDIR=1
+DOCS="ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ if use daap && ! built_with_use net-dns/avahi mono ; then
+ echo
+ eerror "In order to compile banshee with daap support"
+ eerror "you need to have net-dns/avahi emerged"
+ eerror "with 'mono' in your USE flags. Please add that flag, re-emerge"
+ eerror "avahi, and then emerge banshee."
+ die "net-dns/avahi is missing the .NET binding."
+ fi
+
+ if use daap; then
+ G2CONF="${G2CONF} --enable-avahi"
+ else
+ G2CONF="${G2CONF} --disable-daap"
+ fi
+
+ if use boo; then
+ G2CONF="${G2CONF} --enable-external-boo"
+ fi
+
+ G2CONF="${G2CONF} --disable-helix \
+ --disable-docs \
+ $( use_enable ipod) \
+ $( use_enable njb)"
+}
+
+src_compile() {
+ addpredict "/root/.gnome2"
+ addpredict "/root/.gconf"
+ addpredict "/root/.gconfd"
+ gnome2_src_configure
+ emake -j1 || "make failed"
+}
+
+src_install() {
+ gnome2_src_install
+ if ! use ipod; then
+ dodir /usr/$(get_libdir)/banshee/Banshee.Dap
+ fi
+}
+pkg_postinst() {
+ gnome2_pkg_postinst
+ einfo
+ einfo "In case you have an ipod please rebuild this package with USE=ipod"
+ einfo "If you have a audio player supported by libnjb please"
+ einfo "rebuild this package with USE=njb"
+ einfo
+ einfo "If you want to improve your experience with Banshee"
+ einfo "we recommend to emerge media-plugins/banshee-official-plugins"
+ einfo
+}
diff --git a/media-sound/banshee/files/digest-banshee-0.11.5 b/media-sound/banshee/files/digest-banshee-0.11.5
new file mode 100644
index 000000000000..08e266eb6d46
--- /dev/null
+++ b/media-sound/banshee/files/digest-banshee-0.11.5
@@ -0,0 +1,3 @@
+MD5 18ca11c6b67126ce611fa8320bbfe600 banshee-0.11.5.tar.gz 2822704
+RMD160 72b43b28d6c4518b080d33a2dd95c71b77330d80 banshee-0.11.5.tar.gz 2822704
+SHA256 7c92e914dd54095c961bef3c8cc42fd50f0248b8d090133f9a769489753a198d banshee-0.11.5.tar.gz 2822704