summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nikto/nikto-2.1.5.ebuild')
-rw-r--r--net-analyzer/nikto/nikto-2.1.5.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/net-analyzer/nikto/nikto-2.1.5.ebuild b/net-analyzer/nikto/nikto-2.1.5.ebuild
index 74dc7f257607..4bdb97d29324 100644
--- a/net-analyzer/nikto/nikto-2.1.5.ebuild
+++ b/net-analyzer/nikto/nikto-2.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nikto/nikto-2.1.5.ebuild,v 1.2 2014/08/30 18:18:59 monsieurp Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nikto/nikto-2.1.5.ebuild,v 1.3 2014/08/30 20:44:39 monsieurp Exp $
EAPI=5
inherit perl-module
@@ -21,12 +21,12 @@ RDEPEND="dev-lang/perl
)"
src_prepare() {
- sed -i -e 's:config.txt:nikto.conf:g' plugins/* || die
+ sed -i -e 's:config.txt:nikto.conf:g' plugins/*
sed -i -e 's:/etc/nikto.conf:/etc/nikto/nikto.conf:;
s:# EXECDIR=/usr/local/nikto:EXECDIR=/usr/share/nikto:;
s:# use LW2:use LW2:;
- s:require "$CONFIGFILE{'\''PLUGINDIR'\''}/LW2.pm":# require "$CONFIGFILE{'\''PLUGINDIR'\''}/LW2.pm":;' nikto.pl || die
+ s:require "$CONFIGFILE{'\''PLUGINDIR'\''}/LW2.pm":# require "$CONFIGFILE{'\''PLUGINDIR'\''}/LW2.pm":;' nikto.pl
}
src_compile() {
@@ -36,23 +36,24 @@ src_compile() {
src_install() {
insinto /etc/nikto
- doins nikto.conf || die "config install failed"
+ doins nikto.conf
- dobin nikto.pl || die "install failed"
- dosym /usr/bin/nikto.pl /usr/bin/nikto || die
+ dobin nikto.pl
+ dosym /usr/bin/nikto.pl /usr/bin/nikto
- unset ${NIKTO_PMS}
dodir /usr/share/nikto
insinto /usr/share/nikto
- doins -r plugins templates databases || die
+ doins -r plugins templates databases
NIKTO_PMS="LW2.pm JSON-PP.pm"
einfo "symlinking ${NIKTO_PMS} to ${VENDOR_LIB}"
for pm in ${NIKTO_PMS}; do
dosym /usr/share/nikto/plugins/${pm} ${VENDOR_LIB}/${pm}
done
- dodoc docs/*.txt || die
- dohtml docs/nikto_manual.html || die
+ unset ${NIKTO_PMS}
+
+ dodoc docs/*.txt
+ dohtml docs/nikto_manual.html
insinto ${VENDOR_PERL}
}