summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/pnp4nagios')
-rw-r--r--net-analyzer/pnp4nagios/ChangeLog8
-rw-r--r--net-analyzer/pnp4nagios/pnp4nagios-0.4.13.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/net-analyzer/pnp4nagios/ChangeLog b/net-analyzer/pnp4nagios/ChangeLog
index d557fe78f791..bd59dd61092d 100644
--- a/net-analyzer/pnp4nagios/ChangeLog
+++ b/net-analyzer/pnp4nagios/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/pnp4nagios
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/ChangeLog,v 1.7 2009/01/26 19:55:43 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/ChangeLog,v 1.8 2009/02/20 15:43:16 dertobi123 Exp $
+
+*pnp4nagios-0.4.13 (20 Feb 2009)
+
+ 20 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
+ +pnp4nagios-0.4.13.ebuild:
+ Version bump
26 Jan 2009; Brent Baude <ranger@gentoo.org> pnp4nagios-0.4.12.ebuild:
Marking pnp4nagios-0.4.12 ppc64 stable for bug 256177
diff --git a/net-analyzer/pnp4nagios/pnp4nagios-0.4.13.ebuild b/net-analyzer/pnp4nagios/pnp4nagios-0.4.13.ebuild
new file mode 100644
index 000000000000..f90869652012
--- /dev/null
+++ b/net-analyzer/pnp4nagios/pnp4nagios-0.4.13.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/pnp4nagios-0.4.13.ebuild,v 1.1 2009/02/20 15:43:16 dertobi123 Exp $
+
+inherit confutils
+
+MY_P=pnp-${PV}
+
+DESCRIPTION="A performance data analyzer for nagios"
+HOMEPAGE="http://www.pnp4nagios.org"
+
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND=">=dev-lang/php-4.3
+ >=net-analyzer/rrdtool-1.2
+ net-analyzer/nagios-core"
+RDEPEND="${DEPEND}
+ virtual/perl-Getopt-Long
+ virtual/perl-Time-HiRes"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ confutils_require_built_with_all dev-lang/php gd pcre xml zlib
+}
+
+src_compile() {
+ econf \
+ --sysconfdir=/etc/pnp \
+ --datarootdir=/usr/share/pnp \
+ --with-perfdata-dir=/var/nagios/perfdata \
+ --with-perfdata-spool-dir=/var/spool/pnp || die "econf failed"
+ emake all || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" fullinstall || die "emake install failed"
+}
+
+pkg_postinst() {
+ elog "To include the pnp webinterface into your Nagios setup you could use"
+ elog "an Alias in you Apache configuration as follows:"
+
+ elog "\tAlias /nagios/pnp /usr/share/pnp/"
+ elog "\t<Directory "/usr/share/pnp">"
+ elog "\t\tAllowOverride AuthConfig"
+ elog "\t\tOrder allow,deny"
+ elog "\t\tAllow from all"
+ elog "\t</Directory>"
+}