summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/tcpdump/tcpdump-3.9.4-r1.ebuild')
-rw-r--r--net-analyzer/tcpdump/tcpdump-3.9.4-r1.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/net-analyzer/tcpdump/tcpdump-3.9.4-r1.ebuild b/net-analyzer/tcpdump/tcpdump-3.9.4-r1.ebuild
new file mode 100644
index 000000000000..33c1a3cff2b5
--- /dev/null
+++ b/net-analyzer/tcpdump/tcpdump-3.9.4-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-3.9.4-r1.ebuild,v 1.1 2006/03/18 00:11:43 jokey Exp $
+
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="A Tool for network monitoring and data acquisition"
+HOMEPAGE="http://www.tcpdump.org/"
+SRC_URI="http://www.tcpdump.org/release/${P}.tar.gz
+ http://www.jp.tcpdump.org/release/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ssl ipv6"
+
+DEPEND="net-libs/libpcap
+ ssl? ( >=dev-libs/openssl-0.9.6m )"
+
+pkg_setup() {
+ if use samba ; then
+ ewarn
+ ewarn "CAUTION !!! CAUTION !!! CAUTION"
+ ewarn
+ ewarn "You're about to compile tcpdump with samba printing support"
+ ewarn "Upstream tags it as 'possibly-buggy SMB printer'"
+ ewarn "So think twice whether this is fine with you"
+ ewarn
+ ewarn "CAUTION !!! CAUTION !!! CAUTION"
+ ewarn
+ ewarn "(Giving you 10 secs to think about it)"
+ ewarn
+ ebeep 5
+ epause 5
+ fi
+}
+
+src_compile() {
+ # tcpdump needs some optymalization. see bug #108391
+ ( ! is-flag -O? || is-flag -O0 ) && append-flags -O
+
+ replace-flags -O[3-9] -O2
+ filter-flags -finline-functions
+
+ # Fix wrt bug #48747
+ if [[ $(gcc-major-version) -gt 3 ]] || \
+ [[ $(gcc-major-version) -eq 3 && $(gcc-minor-version) -ge 4 ]]
+ then
+ filter-flags -funit-at-a-time
+ append-flags -fno-unit-at-a-time
+ fi
+
+ local myconf
+ if use ssl ; then
+ myconf="--without-crypto"
+ fi
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_with samba smb) \
+ ${myconf} || die "configure failed"
+
+ make CCOPT="$CFLAGS" || die "make failed"
+}
+
+src_install() {
+ dosbin tcpdump || die
+ doman tcpdump.1
+ dodoc *.awk
+ dodoc README FILES VERSION CHANGES
+}