summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/gyach/gyach-0.9.4.ebuild')
-rw-r--r--net-im/gyach/gyach-0.9.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-im/gyach/gyach-0.9.4.ebuild b/net-im/gyach/gyach-0.9.4.ebuild
new file mode 100644
index 000000000000..dab3287d28f6
--- /dev/null
+++ b/net-im/gyach/gyach-0.9.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gyach/gyach-0.9.4.ebuild,v 1.1 2003/10/08 14:10:01 lanius Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK+-based Yahoo! chat client"
+SRC_URI="http://www4.infi.net/~cpinkham/gyach/code/${P}.tar.gz"
+HOMEPAGE="http://www4.infi.net/~cpinkham/gyach/"
+KEYWORDS="x86 sparc "
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/glibc
+ =x11-libs/gtk+-2*"
+
+src_compile() {
+ ./configure --host=${CHOST} --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+ dodoc AUTHORS BUGS COPYING ChangeLog INSTALL README* TODO
+ dodoc sample.*
+
+ # install icon and desktop entry for gnome
+ if [ "`use gnome`" ] ; then
+ insinto /usr/share/pixmaps
+ doins ${D}/usr/share/gyach/pixmaps/gyach-icon.xpm
+ insinto /usr/share/gnome/apps/Internet
+ doins ${FILESDIR}/gyach.desktop
+ fi
+
+}