summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/ctrlproxy')
-rw-r--r--net-irc/ctrlproxy/ChangeLog13
-rw-r--r--net-irc/ctrlproxy/ctrlproxy-2.6.1.ebuild8
-rw-r--r--net-irc/ctrlproxy/ctrlproxy-2.6.2.ebuild36
-rw-r--r--net-irc/ctrlproxy/ctrlproxy-2.6.ebuild8
-rw-r--r--net-irc/ctrlproxy/ctrlproxy-3.0_alpha1.ebuild41
-rw-r--r--net-irc/ctrlproxy/files/digest-ctrlproxy-2.6.23
-rw-r--r--net-irc/ctrlproxy/files/digest-ctrlproxy-3.0_alpha13
7 files changed, 102 insertions, 10 deletions
diff --git a/net-irc/ctrlproxy/ChangeLog b/net-irc/ctrlproxy/ChangeLog
index 3b7aeb4f6ebc..b6035af72031 100644
--- a/net-irc/ctrlproxy/ChangeLog
+++ b/net-irc/ctrlproxy/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-irc/ctrlproxy
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ctrlproxy/ChangeLog,v 1.14 2005/02/07 18:25:01 agriffis Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ctrlproxy/ChangeLog,v 1.15 2006/09/08 22:37:42 agriffis Exp $
+
+*ctrlproxy-3.0_alpha1 (08 Sep 2006)
+*ctrlproxy-2.6.2 (08 Sep 2006)
+
+ 08 Sep 2006; Aron Griffis <agriffis@gentoo.org> ctrlproxy-2.6.ebuild,
+ ctrlproxy-2.6.1.ebuild, +ctrlproxy-2.6.2.ebuild,
+ -ctrlproxy-2.7_pre2.ebuild, +ctrlproxy-3.0_alpha1.ebuild:
+ Bump to 2.6.2 (from 2.6.1) #140669
+ Bump masked version to 3.0_alpha1 (from 2.7_pre2).
*ctrlproxy-2.7_pre2 (07 Feb 2005)
diff --git a/net-irc/ctrlproxy/ctrlproxy-2.6.1.ebuild b/net-irc/ctrlproxy/ctrlproxy-2.6.1.ebuild
index a271939a3a5c..6def9f7a89c5 100644
--- a/net-irc/ctrlproxy/ctrlproxy-2.6.1.ebuild
+++ b/net-irc/ctrlproxy/ctrlproxy-2.6.1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ctrlproxy/ctrlproxy-2.6.1.ebuild,v 1.3 2005/02/07 18:25:01 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ctrlproxy/ctrlproxy-2.6.1.ebuild,v 1.4 2006/09/08 22:37:42 agriffis Exp $
inherit flag-o-matic
DESCRIPTION="IRC proxy with multiserver and multiclient support"
-HOMEPAGE="http://jelmer.vernstok.nl/${PN}/"
-SRC_URI="http://jelmer.vernstok.nl/releases/${P}.tar.gz"
+HOMEPAGE="http://ctrlproxy.vernstok.nl/"
+SRC_URI="http://ctrlproxy.vernstok.nl/releases/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
diff --git a/net-irc/ctrlproxy/ctrlproxy-2.6.2.ebuild b/net-irc/ctrlproxy/ctrlproxy-2.6.2.ebuild
new file mode 100644
index 000000000000..caa905af1c62
--- /dev/null
+++ b/net-irc/ctrlproxy/ctrlproxy-2.6.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ctrlproxy/ctrlproxy-2.6.2.ebuild,v 1.1 2006/09/08 22:37:42 agriffis Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="IRC proxy with multiserver and multiclient support"
+HOMEPAGE="http://ctrlproxy.vernstok.nl/"
+SRC_URI="http://ctrlproxy.vernstok.nl/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~ia64 ~ppc ~x86"
+IUSE="ssl"
+
+DEPEND=">=dev-libs/glib-2
+ dev-libs/popt
+ dev-libs/libxml2
+ dev-libs/tdb
+ dev-libs/libpcre
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ use alpha && append-flags -fPIC
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make install \
+ DESTDIR=${D} \
+ man1dir=/usr/share/man/man1 \
+ man5dir=/usr/share/man/man5 || die
+ gzip ${D}/usr/share/doc/*/*
+ dodoc ctrlproxyrc.example
+}
diff --git a/net-irc/ctrlproxy/ctrlproxy-2.6.ebuild b/net-irc/ctrlproxy/ctrlproxy-2.6.ebuild
index 3181c3f40641..9990762e1f7f 100644
--- a/net-irc/ctrlproxy/ctrlproxy-2.6.ebuild
+++ b/net-irc/ctrlproxy/ctrlproxy-2.6.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ctrlproxy/ctrlproxy-2.6.ebuild,v 1.5 2005/02/07 18:25:01 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ctrlproxy/ctrlproxy-2.6.ebuild,v 1.6 2006/09/08 22:37:42 agriffis Exp $
inherit flag-o-matic
DESCRIPTION="IRC proxy with multiserver and multiclient support"
-HOMEPAGE="http://jelmer.vernstok.nl/${PN}/"
-SRC_URI="http://jelmer.vernstok.nl/releases/${P}.tar.gz"
+HOMEPAGE="http://ctrlproxy.vernstok.nl/"
+SRC_URI="http://ctrlproxy.vernstok.nl/releases/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
diff --git a/net-irc/ctrlproxy/ctrlproxy-3.0_alpha1.ebuild b/net-irc/ctrlproxy/ctrlproxy-3.0_alpha1.ebuild
new file mode 100644
index 000000000000..22c9bceefe7b
--- /dev/null
+++ b/net-irc/ctrlproxy/ctrlproxy-3.0_alpha1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ctrlproxy/ctrlproxy-3.0_alpha1.ebuild,v 1.1 2006/09/08 22:37:42 agriffis Exp $
+
+inherit flag-o-matic
+
+MY_P=${P/_/}
+DESCRIPTION="IRC proxy with multiserver and multiclient support"
+HOMEPAGE="http://ctrlproxy.vernstok.nl/"
+SRC_URI="http://jelmer.vernstok.nl/releases/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~ppc ~ia64"
+IUSE="ssl doc"
+
+DEPEND=">=dev-libs/glib-2
+ dev-libs/popt
+ dev-libs/libxml2
+ dev-libs/tdb
+ dev-libs/libpcre
+ ssl? ( dev-libs/openssl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ # hack alert
+ append-flags -fPIC
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make install \
+ DESTDIR=${D} \
+ man1dir=/usr/share/man/man1 \
+ man5dir=/usr/share/man/man5 \
+ docdir=/usr/share/doc/${P} || die
+ gzip ${D}/usr/share/doc/${P}/*
+ dodoc ctrlproxyrc.example
+}
diff --git a/net-irc/ctrlproxy/files/digest-ctrlproxy-2.6.2 b/net-irc/ctrlproxy/files/digest-ctrlproxy-2.6.2
new file mode 100644
index 000000000000..e8e678835a9c
--- /dev/null
+++ b/net-irc/ctrlproxy/files/digest-ctrlproxy-2.6.2
@@ -0,0 +1,3 @@
+MD5 62fc258cb17902b38b39dc5c5a4e27f9 ctrlproxy-2.6.2.tar.gz 184320
+RMD160 8bc4a9f8e4b54be68af5cd0091558c603c550de5 ctrlproxy-2.6.2.tar.gz 184320
+SHA256 c15f94f89881d6354fc32187ac368b88d8aa13490eab741658ad98c659a0db3a ctrlproxy-2.6.2.tar.gz 184320
diff --git a/net-irc/ctrlproxy/files/digest-ctrlproxy-3.0_alpha1 b/net-irc/ctrlproxy/files/digest-ctrlproxy-3.0_alpha1
new file mode 100644
index 000000000000..72b005352dee
--- /dev/null
+++ b/net-irc/ctrlproxy/files/digest-ctrlproxy-3.0_alpha1
@@ -0,0 +1,3 @@
+MD5 307252f76b52f947fc61f21fc090dc9d ctrlproxy-3.0alpha1.tar.gz 173105
+RMD160 c31d5c03aab91495521749b4761569f9ba640657 ctrlproxy-3.0alpha1.tar.gz 173105
+SHA256 3e82e2f8ec361320a889a37f53b891d925947c04bd4365400c0ab6ce1c8ad4fc ctrlproxy-3.0alpha1.tar.gz 173105