summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/liblockfile/liblockfile-1.06.ebuild')
-rw-r--r--net-libs/liblockfile/liblockfile-1.06.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-libs/liblockfile/liblockfile-1.06.ebuild b/net-libs/liblockfile/liblockfile-1.06.ebuild
new file mode 100644
index 000000000000..2504d1baad8c
--- /dev/null
+++ b/net-libs/liblockfile/liblockfile-1.06.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/liblockfile/liblockfile-1.06.ebuild,v 1.1 2005/05/18 10:56:10 ferdy Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Implements functions designed to lock the standard mailboxes."
+SRC_URI="mirror://debian/pool/main/libl/${PN}/${PN}_${PV}.tar.gz"
+HOMEPAGE="http://www.debian.org"
+
+DEPEND="virtual/libc"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_compile() {
+ econf --with-mailgroup=mail --enable-shared || die
+ emake || die
+}
+
+src_install() {
+ dodir /usr/{bin,include,$(get_libdir)} /usr/share/man/{man1,man3}
+ make ROOT=${D} install || die
+}