summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/linc/linc-0.5.1.ebuild')
-rw-r--r--net-libs/linc/linc-0.5.1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/net-libs/linc/linc-0.5.1.ebuild b/net-libs/linc/linc-0.5.1.ebuild
deleted file mode 100644
index 275a4c01fcb7..000000000000
--- a/net-libs/linc/linc-0.5.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/linc/linc-0.5.1.ebuild,v 1.6 2002/12/09 04:33:13 manson Exp $
-
-IUSE="doc"
-inherit debug
-inherit libtool
-
-
-S=${WORKDIR}/${P}
-DESCRIPTION="A library to ease the writing of networked applications"
-SRC_URI="mirror://gnome/2.0.0/sources/${PN}/${P}.tar.bz2"
-HOMEPAGE="http://www.gnome.org/"
-
-SLOT="0"
-LICENSE="LGPL-2.1"
-KEYWORDS="x86 ppc sparc "
-
-RDEPEND=">=dev-libs/glib-2.0.4-r1
- >=dev-libs/openssl-0.9.6"
-
-DEPEND="${RDEPEND}
- doc? ( >=dev-util/gtk-doc-0.9-r2 )
- >=dev-util/pkgconfig-0.12.0"
-
-src_compile() {
- elibtoolize
- local myconf
- use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
-
- # if this is disabled (use) ORBit2 will fail to build. Just force it on
- myconf="${myconf} --with-openssl"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} \
- --enable-debug=yes || die
- emake || die
-}
-
-src_install() {
- make prefix=${D}/usr \
- sysconfdir=${D}/etc \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- install || die
-
- dodoc AUTHORS ChangeLog COPYING HACKING MAINTAINERS README* INSTALL NEWS TODO
-}