summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/wvstreams/files/wvstreams-4.2.2-sane-cflags.patch')
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.2.2-sane-cflags.patch59
1 files changed, 59 insertions, 0 deletions
diff --git a/net-libs/wvstreams/files/wvstreams-4.2.2-sane-cflags.patch b/net-libs/wvstreams/files/wvstreams-4.2.2-sane-cflags.patch
new file mode 100644
index 000000000000..4435681ccb62
--- /dev/null
+++ b/net-libs/wvstreams/files/wvstreams-4.2.2-sane-cflags.patch
@@ -0,0 +1,59 @@
+diff -Nru wvstreams-4.2.2.orig/vars.mk wvstreams-4.2.2/vars.mk
+--- wvstreams-4.2.2.orig/vars.mk 2007-02-08 20:50:16.000000000 +0200
++++ wvstreams-4.2.2/vars.mk 2007-02-08 20:50:36.000000000 +0200
+@@ -66,10 +66,10 @@
+ CXXFLAGS+=-D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+ CFLAGS+=-D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+
+-ifeq ($(DEBUG),)
+-CXXFLAGS+=-g
+-CFLAGS+=-g
+-endif
++#ifeq ($(DEBUG),)
++#CXXFLAGS+=-g
++#CFLAGS+=-g
++#endif
+
+ ifneq ($(DEBUG),)
+ CXXFLAGS+=-ggdb -DDEBUG$(if $(filter-out yes,$(DEBUG)), -DDEBUG_$(DEBUG))
+@@ -91,9 +91,9 @@
+ endif
+
+ ifneq ("$(enable_optimization)", "no")
+-CXXFLAGS+=-O2
++#CXXFLAGS+=-O2
+ #CXXFLAGS+=-felide-constructors
+-CFLAGS+=-O2
++#CFLAGS+=-O2
+ endif
+
+ ifneq ("$(enable_warnings)", "no")
+diff -Nru wvstreams-4.2.2.orig/wvrules.mk wvstreams-4.2.2/wvrules.mk
+--- wvstreams-4.2.2.orig/wvrules.mk 2007-02-08 20:50:16.000000000 +0200
++++ wvstreams-4.2.2/wvrules.mk 2007-02-08 20:49:04.000000000 +0200
+@@ -82,9 +82,9 @@
+ endif
+
+ ifneq ("$(enable_optimization)", "no")
+- CXXFLAGS+=-O2
++ #CXXFLAGS+=-O2
+ #CXXFLAGS+=-felide-constructors
+- CFLAGS+=-O2
++ #CFLAGS+=-O2
+ endif
+
+ ifneq ("$(enable_warnings)", "no")
+@@ -177,11 +177,11 @@
+ C_AND_CXX_FLAGS += -ggdb -DDEBUG=1
+ LDFLAGS += -ggdb
+ else
+- C_AND_CXX_FLAGS += -g -DDEBUG=0
++ C_AND_CXX_FLAGS += -DDEBUG=0
+ #CFLAGS += -DNDEBUG # I don't like disabling assertions...
+ #CFLAGS += -fomit-frame-pointer # really evil
+ #CXXFLAGS += -fno-implement-inlines # causes trouble with egcs 1.0
+- LDFLAGS += -g
++ #LDFLAGS += -g
+ endif
+
+ ifeq ($(PROFILE),1)