summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/dropbox/dropbox-1.2.24.ebuild')
-rw-r--r--net-misc/dropbox/dropbox-1.2.24.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/dropbox/dropbox-1.2.24.ebuild b/net-misc/dropbox/dropbox-1.2.24.ebuild
new file mode 100644
index 000000000000..71c32e3e0606
--- /dev/null
+++ b/net-misc/dropbox/dropbox-1.2.24.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dropbox/dropbox-1.2.24.ebuild,v 1.1 2011/08/14 12:06:07 naota Exp $
+
+EAPI="4"
+
+DESCRIPTION="Dropbox daemon (pretends to be GUI-less)."
+HOMEPAGE="http://dropbox.com/"
+SRC_URI="x86? ( http://dl-web.dropbox.com/u/17/dropbox-lnx.x86-${PV}.tar.gz )
+ amd64? ( http://dl-web.dropbox.com/u/17/dropbox-lnx.x86_64-${PV}.tar.gz )"
+
+LICENSE="CCPL-Attribution-NoDerivs-3.0 FTL MIT LGPL-2 openssl dropbox"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror strip"
+
+QA_DT_HASH="opt/${PN}/.*"
+QA_EXECSTACK_x86="opt/dropbox/_ctypes.so"
+QA_EXECSTACK_amd64="opt/dropbox/_ctypes.so"
+
+DEPEND=""
+RDEPEND="net-misc/wget"
+
+src_unpack() {
+ unpack ${A}
+ mv "${WORKDIR}/.dropbox-dist" "${S}" || die
+}
+
+src_install() {
+ dodoc README ACKNOWLEDGEMENTS
+ rm README ACKNOWLEDGEMENTS || die
+
+ local targetdir="/opt/dropbox"
+ insinto "${targetdir}"
+ doins -r *
+ fperms a+x "${targetdir}/dropbox"
+ fperms a+x "${targetdir}/dropboxd"
+ dosym "${targetdir}/dropboxd" "/opt/bin/dropbox"
+}