summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/celestia/celestia-1.4.0.ebuild')
-rw-r--r--sci-astronomy/celestia/celestia-1.4.0.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sci-astronomy/celestia/celestia-1.4.0.ebuild b/sci-astronomy/celestia/celestia-1.4.0.ebuild
index 27b35598a3b5..bc1180e66207 100644
--- a/sci-astronomy/celestia/celestia-1.4.0.ebuild
+++ b/sci-astronomy/celestia/celestia-1.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.4.0.ebuild,v 1.4 2006/01/19 07:31:12 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.4.0.ebuild,v 1.5 2006/01/31 05:16:35 morfic Exp $
inherit eutils flag-o-matic gnome2 kde-functions
@@ -82,8 +82,10 @@ src_compile() {
|| die "econf failed"
#fix Makefiles to avoid Access Violations while fixing bug #119339
+ if ! use gnome ; then
for d in . src data extras textures textures/lores textures/medres textures/hires models shaders fonts po ; do
sed -i -e "s#pkgdatadir = /usr/share/celestia#pkgdatadir = ${D}/usr/share/celestia#" $d/Makefile; done
+ fi
emake || die "emake failed"
}