summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/kapteyn/kapteyn-2.1.ebuild')
-rw-r--r--sci-astronomy/kapteyn/kapteyn-2.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-astronomy/kapteyn/kapteyn-2.1.ebuild b/sci-astronomy/kapteyn/kapteyn-2.1.ebuild
new file mode 100644
index 000000000000..b59947ea888f
--- /dev/null
+++ b/sci-astronomy/kapteyn/kapteyn-2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/kapteyn/kapteyn-2.1.ebuild,v 1.1 2011/02/17 06:45:58 bicatali Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Collection of python tools for astronomy"
+HOMEPAGE="http://www.astro.rug.nl/software/kapteyn"
+SRC_URI="http://www.astro.rug.nl/software/kapteyn/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=sci-astronomy/wcslib-4.7
+ dev-python/numpy"
+RDEPEND="${DEPEND}"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_install() {
+ distutils_src_install
+ dodoc doc/${PN}.pdf || die
+}