summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/hcalc/hcalc-1.0.ebuild')
-rw-r--r--sci-calculators/hcalc/hcalc-1.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-calculators/hcalc/hcalc-1.0.ebuild b/sci-calculators/hcalc/hcalc-1.0.ebuild
new file mode 100644
index 000000000000..d4352152a3eb
--- /dev/null
+++ b/sci-calculators/hcalc/hcalc-1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/hcalc/hcalc-1.0.ebuild,v 1.1 2004/12/24 14:56:10 ribosome Exp $
+
+DESCRIPTION="DJ's Hex Calculator"
+HOMEPAGE="http://www.delorie.com/store/hcalc/"
+SRC_URI="http://www.delorie.com/store/hcalc/${PN}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~amd64"
+IUSE=""
+
+DEPEND="virtual/x11"
+
+S=${WORKDIR}
+
+src_compile() {
+ sed 's|'-lX11'|'"-lX11 -L/usr/X11R6/lib"'|' Makefile > Makefile_fixed
+ make -f Makefile_fixed || die
+}
+
+src_install() {
+ dobin hcalc
+}
+
+pkg_postinst() {
+ einfo "Enter hcalc to run and use kill or ctrl-c to exit."
+}
+