summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/openbabel-python/files/openbabel-python-2.3.1-system_openbabel.patch')
-rw-r--r--sci-chemistry/openbabel-python/files/openbabel-python-2.3.1-system_openbabel.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/sci-chemistry/openbabel-python/files/openbabel-python-2.3.1-system_openbabel.patch b/sci-chemistry/openbabel-python/files/openbabel-python-2.3.1-system_openbabel.patch
new file mode 100644
index 000000000000..6420bba11e8a
--- /dev/null
+++ b/sci-chemistry/openbabel-python/files/openbabel-python-2.3.1-system_openbabel.patch
@@ -0,0 +1,15 @@
+--- scripts/python/setup.py
++++ scripts/python/setup.py
+@@ -15,11 +15,7 @@
+
+ obExtension = Extension('_openbabel',
+ [os.path.join(srcdir, "openbabel-python.cpp")],
+- include_dirs=[os.path.join(srcdir, "..", "..", "include"),
+- os.path.join("..", "include")],
+- library_dirs=[os.path.join(srcdir, "..", "..", "lib"),
+- os.path.join(srcdir, "..", "..", "lib64"),
+- os.path.join("..", "lib")],
++ include_dirs=[os.path.join("/usr", "include", "openbabel-2.0")],
+ libraries=['openbabel']
+ )
+