summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/babel/ChangeLog6
-rw-r--r--sci-chemistry/babel/babel-1.6-r1.ebuild31
-rw-r--r--sci-chemistry/babel/babel-1.6.ebuild22
-rw-r--r--sci-chemistry/babel/metadata.xml2
4 files changed, 29 insertions, 32 deletions
diff --git a/sci-chemistry/babel/ChangeLog b/sci-chemistry/babel/ChangeLog
index 22dab00a3430..7c424956459d 100644
--- a/sci-chemistry/babel/ChangeLog
+++ b/sci-chemistry/babel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/babel
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/babel/ChangeLog,v 1.7 2011/04/30 18:07:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/babel/ChangeLog,v 1.8 2011/06/25 18:08:12 jlec Exp $
+
+ 25 Jun 2011; Justin Lecher <jlec@gentoo.org> babel-1.6.ebuild,
+ babel-1.6-r1.ebuild, metadata.xml:
+ Cleaned ebuild, moved EAPI=4
30 Apr 2011; Raúl Porcel <armin76@gentoo.org> babel-1.6.ebuild,
babel-1.6-r1.ebuild:
diff --git a/sci-chemistry/babel/babel-1.6-r1.ebuild b/sci-chemistry/babel/babel-1.6-r1.ebuild
index db054a0e5bec..0ed81022c92a 100644
--- a/sci-chemistry/babel/babel-1.6-r1.ebuild
+++ b/sci-chemistry/babel/babel-1.6-r1.ebuild
@@ -1,13 +1,15 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/babel/babel-1.6-r1.ebuild,v 1.2 2011/04/30 18:07:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/babel/babel-1.6-r1.ebuild,v 1.3 2011/06/25 18:08:12 jlec Exp $
-inherit eutils
+EAPI=4
-DESCRIPTION="Babel is a program to interconvert file formats used in molecular modeling."
+inherit eutils
+DESCRIPTION="Interconvert file formats used in molecular modeling"
SRC_URI="http://smog.com/chem/babel/files/${P}.tar.Z"
HOMEPAGE="http://smog.com/chem/babel/"
+
KEYWORDS="~amd64 ~ppc ~x86"
SLOT="0"
LICENSE="as-is"
@@ -15,24 +17,21 @@ IUSE=""
#Doesn't really seem to depend on anything (?)
DEPEND="!sci-chemistry/openbabel"
+RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc32.diff
- epatch "${FILESDIR}"/${P}-makefile.patch
-}
-
-src_compile() {
- CC=$(tc-getCC) emake || die "emake failed"
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc32.diff \
+ "${FILESDIR}"/${P}-makefile.patch
+ tc-export CC
}
src_install () {
- make DESTDIR="${D}"/usr/bin install || die
+ default
insinto /usr/share/${PN}
- doins *.lis || die "Failed to install *.lis files"
+ doins *.lis
- doenvd "${FILESDIR}"/10babel || die "doenvd failed"
- dodoc README.1ST || die "dodoc failed"
+ doenvd "${FILESDIR}"/10babel
+ dodoc README.1ST
}
diff --git a/sci-chemistry/babel/babel-1.6.ebuild b/sci-chemistry/babel/babel-1.6.ebuild
index 00c7356faf57..9bafecc8a5e0 100644
--- a/sci-chemistry/babel/babel-1.6.ebuild
+++ b/sci-chemistry/babel/babel-1.6.ebuild
@@ -1,14 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/babel/babel-1.6.ebuild,v 1.6 2011/04/30 18:07:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/babel/babel-1.6.ebuild,v 1.7 2011/06/25 18:08:12 jlec Exp $
inherit eutils
-DESCRIPTION="Babel is a program to interconvert file formats used in molecular modeling."
-
+DESCRIPTION="Interconvert file formats used in molecular modeling"
SRC_URI="http://smog.com/chem/babel/files/${P}.tar.Z"
-
HOMEPAGE="http://smog.com/chem/babel/"
+
KEYWORDS="~amd64 ppc x86"
SLOT="0"
LICENSE="as-is"
@@ -16,32 +15,27 @@ IUSE=""
#Doesn't really seem to depend on anything (?)
DEPEND="!sci-chemistry/openbabel"
+RDEPEND="${DEPEND}"
src_unpack() {
-
unpack ${P}.tar.Z
cd "${S}"
#Patch the Makefile for gentoo-isms
- epatch "${FILESDIR}"/${P}-gentoo.diff
- epatch "${FILESDIR}"/${P}-gcc32.diff
-
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.diff\
+ "${FILESDIR}"/${P}-gcc32.diff
}
src_compile() {
-
emake || die
-
}
src_install () {
-
- make DESTDIR="${D}"/usr/bin install || die
+ emake DESTDIR="${D}"/usr/bin install || die
insinto /usr/share/${PN}
doins "${S}"/*.lis
doenvd "${FILESDIR}"/10babel
-
dodoc README.1ST
-
}
diff --git a/sci-chemistry/babel/metadata.xml b/sci-chemistry/babel/metadata.xml
index 9ac9ffdb3a41..e42d0af60f42 100644
--- a/sci-chemistry/babel/metadata.xml
+++ b/sci-chemistry/babel/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-chemistry</herd>
+ <herd>sci-chemistry</herd>
</pkgmetadata>